aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2021-06-30 10:29:36 -0600
committerTim Harder <radhermit@gmail.com>2021-06-30 10:42:31 -0600
commit0b0d775f9fdf576599e5d06a488081e8b873715b (patch)
treee7b05cf54a173ce9677ccc0e73e558cdc6b608d8 /tests
parentbump version (diff)
downloadpkgdev-0b0d775f9fdf576599e5d06a488081e8b873715b.tar.gz
pkgdev-0b0d775f9fdf576599e5d06a488081e8b873715b.tar.bz2
pkgdev-0b0d775f9fdf576599e5d06a488081e8b873715b.zip
pkgdev commit: properly generate pkg rename summaries
Diffstat (limited to 'tests')
-rw-r--r--tests/scripts/test_pkgdev_commit.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/scripts/test_pkgdev_commit.py b/tests/scripts/test_pkgdev_commit.py
index b692b53..19e1938 100644
--- a/tests/scripts/test_pkgdev_commit.py
+++ b/tests/scripts/test_pkgdev_commit.py
@@ -509,9 +509,14 @@ class TestPkgdevCommit:
os.remove(pjoin(git_repo.path, f'cat/pkg/pkg-{v}.ebuild'))
assert commit() == 'cat/pkg: drop versions'
- # treeclean
+ # package rename
+ shutil.copytree(pjoin(git_repo.path, 'cat/pkg'), pjoin(git_repo.path, 'newcat/pkg'))
shutil.rmtree(pjoin(git_repo.path, 'cat/pkg'))
- assert commit() == 'cat/pkg: treeclean'
+ assert commit() == 'newcat/pkg: rename cat/pkg'
+
+ # treeclean
+ shutil.rmtree(pjoin(git_repo.path, 'newcat/pkg'))
+ assert commit() == 'newcat/pkg: treeclean'
def test_non_gentoo_file_mangling(self, repo, make_git_repo):
git_repo = make_git_repo(repo.location)