summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--patches/03_all_libdir.patch11
-rw-r--r--patches/23_all_h2py_encoding.patch4
2 files changed, 13 insertions, 2 deletions
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index e85d646..c07a6ff 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -223,3 +223,14 @@
# If Cygwin, then verify that X is installed before proceeding
if host_platform == 'cygwin':
+--- configure.ac
++++ configure.ac
+@@ -4374,7 +4374,7 @@
+
+ dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
+ AC_SUBST(PY_ENABLE_SHARED)
+-LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
++LIBPL='$(prefix)'"/@@GENTOO_LIBDIR@@/python${VERSION}/config-${LDVERSION}"
+ AC_SUBST(LIBPL)
+
+ # Check whether right shifting a negative integer extends the sign bit
diff --git a/patches/23_all_h2py_encoding.patch b/patches/23_all_h2py_encoding.patch
index 8a0fbb4..f472b7c 100644
--- a/patches/23_all_h2py_encoding.patch
+++ b/patches/23_all_h2py_encoding.patch
@@ -15,8 +15,8 @@ https://bugs.python.org/issue13032
+ b'^[\t ]*#[\t ]*define[\t ]+'
+ b'([a-zA-Z0-9_]+)\(([_a-zA-Z][_a-zA-Z0-9]*)\)[\t ]+')
--p_include = re.compile('^[\t ]*#[\t ]*include[\t ]+<([a-zA-Z0-9_/\.]+)')
-+p_include = re.compile(b'^[\t ]*#[\t ]*include[\t ]+<([a-zA-Z0-9_/\.]+)')
+-p_include = re.compile('^[\t ]*#[\t ]*include[\t ]+<([^>\n]+)>')
++p_include = re.compile(b'^[\t ]*#[\t ]*include[\t ]+<([^>\n]+)>')
-p_comment = re.compile(r'/\*([^*]+|\*+[^/])*(\*+/)?')
-p_cpp_comment = re.compile('//.*')