aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.gpyutils12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 52e1ce2..df7547d 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -6,7 +6,7 @@ timestamp = $(PORTDIR)/metadata/timestamp.commit
outdir = /dev/null
# upgrades for stable impls
-upgr_base = $(outdir)/310-to-311.txt
+upgr_base = $(outdir)/310-to-311.txt #$(outdir)/311-to-312.txt
# related stabilizations
upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
# all upgrade stuff
@@ -20,6 +20,16 @@ all = $(upgr_all)
all: $(all)
+$(outdir)/311-to-312.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m python3_11 python3_12 > $@.new
+ mv $@.new $@
+
+#$(outdir)/311-to-312-stablereq.txt: $(timestamp)
+# mkdir -p $(outdir)
+# gpy-upgrade-impl -m -s python3_11 python3_12 > $@.new
+# mv $@.new $@
+
$(outdir)/310-to-311.txt: $(timestamp)
mkdir -p $(outdir)
gpy-upgrade-impl -m python3_10 python3_11 > $@.new