aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-18 15:46:22 +0100
committerJustin Lecher <jlec@gentoo.org>2017-03-18 21:06:56 +0000
commit86cdee3a3ca7ac2d287010be56cfc7c00f75064a (patch)
treea918752717dd2a8d9127c37f7aafa58fdb55c9f0
parentsci-biology/wgs_tools: fix install procedure (diff)
downloadsci-86cdee3a3ca7ac2d287010be56cfc7c00f75064a.tar.gz
sci-86cdee3a3ca7ac2d287010be56cfc7c00f75064a.tar.bz2
sci-86cdee3a3ca7ac2d287010be56cfc7c00f75064a.zip
sci-biology/RADtools: fix installation procedure
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-biology/RADtools/RADtools-1.2.4.ebuild12
-rw-r--r--sci-biology/RADtools/RADtools-9999.ebuild13
2 files changed, 12 insertions, 13 deletions
diff --git a/sci-biology/RADtools/RADtools-1.2.4.ebuild b/sci-biology/RADtools/RADtools-1.2.4.ebuild
index 43e0b8b04..d316384e2 100644
--- a/sci-biology/RADtools/RADtools-1.2.4.ebuild
+++ b/sci-biology/RADtools/RADtools-1.2.4.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
-inherit perl-module
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit eutils perl-module
DESCRIPTION="Tools for processing RAD Sequencing Illumina reads"
HOMEPAGE="https://www.wiki.ed.ac.uk/display/RADSequencing/Home"
@@ -25,9 +26,8 @@ S="${WORKDIR}"
src_install() {
dobin RADMIDs RADmarkers RADpools RADtags
- mydoc="CHANGELOG RADmanual.pdf RADmanual.tex README"
- eval `perl '-V:installvendorlib'` || die
- vendor_lib_install_dir="${installvendorlib}"
- insinto ${vendor_lib_install_dir}
+ dodoc CHANGELOG RADmanual.pdf RADmanual.tex README
+ perl_set_version
+ insinto "${VENDOR_LIB}"
doins *.pm
}
diff --git a/sci-biology/RADtools/RADtools-9999.ebuild b/sci-biology/RADtools/RADtools-9999.ebuild
index 61be80e95..b1d09180e 100644
--- a/sci-biology/RADtools/RADtools-9999.ebuild
+++ b/sci-biology/RADtools/RADtools-9999.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
-inherit perl-module git-r3
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit eutils perl-module git-r3
DESCRIPTION="Tools for processing RAD Sequencing Illumina reads"
HOMEPAGE="https://www.wiki.ed.ac.uk/display/RADSequencing/Home"
@@ -22,10 +23,8 @@ RDEPEND="${DEPEND}"
src_install() {
dobin RADMIDs RADmarkers RADpools RADtags
- mydoc="CHANGELOG RADmanual.pdf RADmanual.tex README"
- eval `perl '-V:installvendorlib'` || die
- vendor_lib_install_dir="${installvendorlib}"
-
- insinto ${vendor_lib_install_dir}
+ dodoc CHANGELOG RADmanual.pdf RADmanual.tex README
+ perl_set_version
+ insinto "${VENDOR_LIB}"
doins *.pm
}