aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2007-07-14 12:28:56 -0700
committerJosh Triplett <josh@freedesktop.org>2007-07-14 12:28:56 -0700
commitfa8fd13f0b27306a4c210b9092cb40324e8399e3 (patch)
treee522bc427bf20e5830169fe088e594f6e9cba575 /Makefile
parent[PATCH] deal correctly with qualifiers on arrays (diff)
downloadsparse-fa8fd13f0b27306a4c210b9092cb40324e8399e3.tar.gz
sparse-fa8fd13f0b27306a4c210b9092cb40324e8399e3.tar.bz2
sparse-fa8fd13f0b27306a4c210b9092cb40324e8399e3.zip
Split c2xml build rule into compile and link stages, and add the quiet prefixes
Signed-off-by: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index cedf092..d306f5b 100644
--- a/Makefile
+++ b/Makefile
@@ -116,11 +116,8 @@ test-dissect: test-dissect.o $(LIBS)
ctags: ctags.o $(LIBS)
$(QUIET_LINK)$(CC) $(LDFLAGS) -o $@ $< $(LIBS)
-ifeq ($(HAVE_LIBXML),yes)
-c2xml: c2xml.c $(LIBS) $(LIB_H)
- $(CC) $(LDFLAGS) `pkg-config --cflags --libs libxml-2.0` -o $@ $< $(LIBS)
-
-endif
+c2xml: c2xml.o $(LIBS)
+ $(QUIET_LINK)$(CC) $(LDFLAGS) `pkg-config --libs libxml-2.0` -o $@ $< $(LIBS)
$(LIB_FILE): $(LIB_OBJS)
$(QUIET_AR)$(AR) rcs $@ $(LIB_OBJS)
@@ -162,6 +159,9 @@ storage.o: $(LIB_H)
dissect.o: $(LIB_H)
graph.o: $(LIB_H)
+c2xml.o: c2xml.c $(LIB_H)
+ $(QUIET_CC)$(CC) `pkg-config --cflags libxml-2.0` -o $@ -c $(CFLAGS) $<
+
compat-linux.o: compat/strtold.c compat/mmap-blob.c \
$(LIB_H)
compat-solaris.o: compat/mmap-blob.c $(LIB_H)