summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-07-16 13:02:11 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-16 13:02:11 +0200
commit628cef9486ddab3f691bbeac9a99af03cf64242c (patch)
tree70f591b8d29c82e6c21d5a63809685fdc5dcfe1d /xen-4.16-efi.patch
parentcommit-and-tag: only commit if there is something to commit (diff)
downloadxen-gentoo-patches-628cef9486ddab3f691bbeac9a99af03cf64242c.tar.gz
xen-gentoo-patches-628cef9486ddab3f691bbeac9a99af03cf64242c.tar.bz2
xen-gentoo-patches-628cef9486ddab3f691bbeac9a99af03cf64242c.zip
Gentoo specific patches for Xen 4.16.1 (or later)4.16.1-gentoo-patchset-24.16
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'xen-4.16-efi.patch')
-rw-r--r--xen-4.16-efi.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/xen-4.16-efi.patch b/xen-4.16-efi.patch
new file mode 100644
index 0000000..0de5575
--- /dev/null
+++ b/xen-4.16-efi.patch
@@ -0,0 +1,12 @@
+diff -urN a/xen/arch/x86/Makefile b/xen/arch/x86/Makefile
+--- a/xen/arch/x86/Makefile 2021-11-30 06:42:42.000000000 -0500
++++ b/xen/arch/x86/Makefile 2022-02-17 07:43:06.597244620 -0500
+@@ -127,7 +127,7 @@
+ CFLAGS-$(XEN_BUILD_EFI) += -DXEN_BUILD_EFI
+
+ # Check if the linker supports PE.
+-EFI_LDFLAGS = $(patsubst -m%,-mi386pep,$(XEN_LDFLAGS)) --subsystem=10
++EFI_LDFLAGS = -mi386pep $(patsubst -m%,-mi386pep,$(XEN_LDFLAGS)) --subsystem=10
+ XEN_BUILD_PE := $(if $(XEN_BUILD_EFI),$(call ld-option,$(EFI_LDFLAGS) --image-base=0x100000000 -o efi/check.efi efi/check.o))
+ # If the above failed, it may be merely because of the linker not dealing well
+ # with debug info. Try again with stripping it.