summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-17 00:34:55 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-17 11:56:00 -0500
commitb5140e124318752a13942e2d4d3e15469bdd7e22 (patch)
treef0fc31118f0eb2f81b15f949d8a2de6ea3a719f1
parentsys-libs/libhx: Add subslot (diff)
downloadgentoo-b5140e124318752a13942e2d4d3e15469bdd7e22.tar.gz
gentoo-b5140e124318752a13942e2d4d3e15469bdd7e22.tar.bz2
gentoo-b5140e124318752a13942e2d4d3e15469bdd7e22.zip
sys-libs/libhx: Version bump to 3.25
Closes: https://bugs.gentoo.org/730726 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-libs/libhx/Manifest1
-rw-r--r--sys-libs/libhx/libhx-3.25.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/libhx/Manifest b/sys-libs/libhx/Manifest
index 0f03520f157a..dd169cc59c4d 100644
--- a/sys-libs/libhx/Manifest
+++ b/sys-libs/libhx/Manifest
@@ -1 +1,2 @@
DIST libHX-3.24.tar.xz 876992 BLAKE2B 518b99e78acc0cb412f444c0dacaae830a853294a0ee549facfbe65a423a9f32d0388e30e255c87c3f5325102bea45e5e9d72d3fce5b89139b689fddcb299f93 SHA512 faf7af53b628efe1531568ccb2b7e9910db833b14583ab1487eb6a554b407a7546bc75348f7d2344c29ab53fd2df061f6f8de8db634bbd62c3672dc4347d27e4
+DIST libHX-3.25.tar.xz 890576 BLAKE2B d8e13a7fb0ea2cd033edc6b179ef3d4b30c37f522b1e90aea0de96d225655b654d1a7cb133834ef2f10044ccbe60e7559b2280ecbc136a458fd3a2237b8f83ab SHA512 221000fddd1316b6c452babbcb7e234683e3bad559a4b1a608936a086143ad8f17cec489606f8d50ea66775b9f8305ec52c7401d568f01b33372388f75bdea94
diff --git a/sys-libs/libhx/libhx-3.25.ebuild b/sys-libs/libhx/libhx-3.25.ebuild
new file mode 100644
index 000000000000..5f6d32a514e4
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.25.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Platform independent library providing basic system functions"
+HOMEPAGE="https://inai.de/projects/libhx/"
+SRC_URI="https://inai.de/files/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/32" # soname version
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S="${WORKDIR}/libHX-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.22-no-lyx.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dodoc doc/*.txt
+ else
+ dodoc doc/changelog.txt
+ rm "${ED}/usr/share/doc/${PF}/"*.pdf || die
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}