summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-03-19 15:29:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-03-19 15:29:48 -0500
commit9ab1cd1b5a414869290595996b147e3f1269f0e0 (patch)
tree459daa166222910b360d9569e8b7c22a2dea1668 /app-containers/cosign
parentdev-lua/lua-unbound: add missing deps (diff)
downloadgentoo-9ab1cd1b5a414869290595996b147e3f1269f0e0.tar.gz
gentoo-9ab1cd1b5a414869290595996b147e3f1269f0e0.tar.bz2
gentoo-9ab1cd1b5a414869290595996b147e3f1269f0e0.zip
app-containers/cosign: add 1.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/cosign')
-rw-r--r--app-containers/cosign/Manifest2
-rw-r--r--app-containers/cosign/cosign-1.6.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/app-containers/cosign/Manifest b/app-containers/cosign/Manifest
index 4a520983fa8c..f77497bb2da7 100644
--- a/app-containers/cosign/Manifest
+++ b/app-containers/cosign/Manifest
@@ -1,2 +1,4 @@
DIST cosign-1.5.2-vendor.tar.xz 10097760 BLAKE2B 836dae79dc596193f40826e9c203312f2e9b56d2371d22db6880a49b52e3b37741a0b0adda6ec717ce983e81e964d3ef75d4a3507c8fc03628b4a63e8d071dfb SHA512 a0362652b5b6a41997e125df45d84d5536f23fcb917eb5211d3adc0f90713e3fd8439974cd727d259a3fe8fae5a8b1882ef24685a8293ef0176327468e3f4997
DIST cosign-1.5.2.tar.gz 6597815 BLAKE2B b1dd4c49c1f561f1e449a5884f62731fdefb79c8b4d234a27ab48483a7421d0581e68bf132b88830498e9153fe65a5a5b2b903b63cbfa56892c1db0cef8c2751 SHA512 f52b07410081dec66ab3f12ab2b52690686bcd6144703cb107c42c72d9514a94d227f653ecb9047e2fae8f5e763b6afaf703edd6a0c5b62fe9acb612eed9b43f
+DIST cosign-1.6.0-deps.tar.xz 532055072 BLAKE2B c9192d5e4dae37d0f3826bec3a945812776d513af474cf0bcbba33eeda2b5e26f9166e69b3f9f3e3591361dac70a6b49c90e4b087899138bf8f1196db757b346 SHA512 8894eaddd3009f6c50e5e3cc681b8f0e78950d497f8808dee501305a137eed83e3cfd7382a1f171361aba271bd0d0c27dcb3d0d3907d970982e9748e8ba97273
+DIST cosign-1.6.0.tar.gz 7069651 BLAKE2B 74ef05aacc19bfb627039bc9b7a7ec981b2ad80e3ef779d2b538369243b1727c51808dd8b45e5514bc1d798fef8f8d07d9fd22c36df11d29c44316d36e77900f SHA512 d812fbb8861ee9ddf117a4f9b6d1e9d90f3ecf1d9f396beef73b381caf30ef73162ac081dcf5e6abe18a21ca16fc8e99b299166543a5d7c72085e0fb821dc712
diff --git a/app-containers/cosign/cosign-1.6.0.ebuild b/app-containers/cosign/cosign-1.6.0.ebuild
new file mode 100644
index 000000000000..ce97639ed60d
--- /dev/null
+++ b/app-containers/cosign/cosign-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_HASH=4b2c3c0c8ee97f31b9dac3859b40e0a48b8648ee
+inherit go-module
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-fix-makefile.patch
+)
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH}
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+}