summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-16 00:07:07 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-16 00:23:29 +0200
commita2fd4ea342648a6285b740952f76b4289852fea5 (patch)
tree35f0c3aaeee50c69a23a5149d03a306ac45d6368 /app-emacs
parentapp-emacs/ebib: bump to 2.42 (diff)
downloadgentoo-a2fd4ea342648a6285b740952f76b4289852fea5.tar.gz
gentoo-a2fd4ea342648a6285b740952f76b4289852fea5.tar.bz2
gentoo-a2fd4ea342648a6285b740952f76b4289852fea5.zip
app-emacs/yasnippet: bump to 0.14.1_p20240406
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yasnippet/Manifest1
-rw-r--r--app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/yasnippet/Manifest b/app-emacs/yasnippet/Manifest
index 19bc254c6b2b..1d310de820fb 100644
--- a/app-emacs/yasnippet/Manifest
+++ b/app-emacs/yasnippet/Manifest
@@ -1 +1,2 @@
DIST yasnippet-0.14.0.tar.gz 581053 BLAKE2B efae02939d0174724803819fb9a47a414acad3b1d58da91d4f35c42c02282db9773f4f3caa020d01c2d87de741d3c60b39e1406b6ff7b3e5310ed4efc477d635 SHA512 c7f704187b3c700f8ea9e0205941d7a32602b6994307007cb83aa984ccf7e7e37be9589277a56c294703eab82ee4b1dffae7040f2e175e7d56cda5ef3c70eb39
+DIST yasnippet-0.14.1_p20240406.tar.gz 581059 BLAKE2B 44ae910a495ba7c507ef1316cc358116ed984af69314316ae7a78c41ae6f84c4406e0959848f229c9546240c98d01e99d1accb5e9b6b8aeed3a7191f9ab918d4 SHA512 6aca3aef7b4a4b6cc03a7926fa6203758b1124c92e906d3eb355f2ee8bee95e4ca2a8a8929b4e7837f8999b23e66dc68429bb4117dde90d92f21ddd76cbb1c70
diff --git a/app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild b/app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild
new file mode 100644
index 000000000000..1b9e803b5903
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="https://joaotavora.github.io/yasnippet/
+ https://github.com/joaotavora/yasnippet/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joaotavora/${PN}.git"
+else
+ [[ "${PV}" == *p20240406 ]] && COMMIT="e23a80177a9c434174ed8a5955c296d7828a1060"
+
+ SRC_URI="https://github.com/joaotavora/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+SITEFILE="50${PN}-gentoo-0.13.0.el"
+
+elisp-enable-tests ert -L . -l yasnippet-tests
+
+src_install() {
+ elisp-install "${PN}" yasnippet.{el,elc} yasnippet-debug.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc CONTRIBUTING.md NEWS README.mdown
+ use doc && dodoc -r doc/*
+
+ local DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ \n\t(require 'yasnippet)
+ \n\t(yas-global-mode 1)
+ \n\nYASnippet no longer bundles snippets directly. Install the package
+ app-emacs/yasnippet-snippets for a collection of snippets."
+ readme.gentoo_create_doc
+}