summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-02 05:07:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-02 05:43:29 +0200
commitd63ae0d8a2d67a90f069195e8a43ba05d07ae108 (patch)
tree1a7426ace791e1d723f66899b579a06ed105d985 /app-emacs
parentapp-emacs/denote: drop old 2.3.0 (diff)
downloadgentoo-d63ae0d8a2d67a90f069195e8a43ba05d07ae108.tar.gz
gentoo-d63ae0d8a2d67a90f069195e8a43ba05d07ae108.tar.bz2
gentoo-d63ae0d8a2d67a90f069195e8a43ba05d07ae108.zip
app-emacs/jinx: bump to 1.9
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/jinx/Manifest1
-rw-r--r--app-emacs/jinx/jinx-1.9.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index 0d0c18d3ff62..6b0a95ddce82 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,2 +1,3 @@
DIST jinx-1.6.tar.gz 34624 BLAKE2B 57917120dd6b10e30d989f056d3587452b2a2fe4db97df989de25c31ae7dd0e56ab2fd40cb92e570cd076209ab039ae0a8cc1ba7cb42210acbc4a1a07cef5f52 SHA512 b4e2b7ef03036e79c91e2a3d2c39ec6505ac9b6b2f7b32cfeee961448b4015de87c60adc9c14de3faccab14d7be75a77622fb0e21982a6e3fdcd58046c54d471
DIST jinx-1.7.tar.gz 34795 BLAKE2B 96f5ea43c59692ffcf628438144bf07d297f8f82072a4e27282e8e10777769ad8876dd4b9057d59ede5cd7ac7d9c48bd197e5bd3175239332b52b29eba276e0b SHA512 2d92cf7822494b1eca5e746104610fcaedc09427dad9ac45cb901a19ee663a5300f7d5b5768155bc0ec41c3a96208b0233932fd13bb8ab00fc88e766d5aec538
+DIST jinx-1.9.tar.gz 35118 BLAKE2B 1db0bf43978f0d3d521b864a6b71c98642a7bfd1517dfb91425776ccbb320f7b52c8c05360722e79bf294140043e65bb057372570ea0851f917824545b93db09 SHA512 18124ebfa0da7362d9265f4681267881849f566db10e7ea49e20f88ea0cdce0b3af76f78313849c2fa4ed0c24734ffda34aba95c86b3aeaf50db414f566a167e
diff --git a/app-emacs/jinx/jinx-1.9.ebuild b/app-emacs/jinx/jinx-1.9.ebuild
new file mode 100644
index 000000000000..4faa877e1994
--- /dev/null
+++ b/app-emacs/jinx/jinx-1.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+ doinfo jinx.info
+}