summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-10-12 18:45:35 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-10-12 18:51:08 +0900
commit537e12ef200c1b18810eb78bd9505f579da0cb98 (patch)
treea19dc7fe00aa308fe61ed90ebc39b8ad512ba278 /app-i18n
parentapp-i18n/ibus-table-others: new upstream release (diff)
downloadgentoo-537e12ef200c1b18810eb78bd9505f579da0cb98.tar.gz
gentoo-537e12ef200c1b18810eb78bd9505f579da0cb98.tar.bz2
gentoo-537e12ef200c1b18810eb78bd9505f579da0cb98.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.18.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 05696dc1ffa8..4c4b7298dc47 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.25.14.tar.gz 13450399 BLAKE2B 2a8d5b823e51aee782bede9ddd08b10217744a646f309b46e320359631aee76c4b451d124d365e2b843b09cb8263603da490e99eef0073b8487ff4e42a079f73 SHA512 1687d2c4e51ffc8b84895845c7d37c3d6e186211fe0b2dd4f9bfc2f36168dc3bc993b8cfdc2e49ce108dfe7d1d9bdbc81480e952b832950fcccc53c9e523fe92
DIST ibus-typing-booster-2.25.15.tar.gz 13237545 BLAKE2B 0844b1a35a7aae46abc22a5181992c87770f8083f1cab1fc5fe482db0bde76c3b51b58777da7588cf48787dfa90a811f83c57ed1dce9eb9ce1d6ec7236d9fbeb SHA512 0a8228c525eebe57f2de117cde480164231f03edd0d0f720c176aab366d6964a5e10ea70ae3976e99630e03af1505c1eadf8580d04bcf8cfef460d7e07c467ed
+DIST ibus-typing-booster-2.25.18.tar.gz 13294821 BLAKE2B ee88e528bd5707b910338a886a0dda54f38c6547936e423c848257efcaa2e5385eb854acee51870470f0dc0493ec96d885c9eb8a4cc660dda8cd5f8b62e9ed4e SHA512 57fb90658eaf55647ac4e501842e7ebe72aaf0dbe3979b64b141785827be5780f9cbd7ba52cf988c2845eac54fd898c4aa0a886517fcc3150edeb701708772ff
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.18.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.18.ebuild
new file mode 100644
index 000000000000..97351b6920ac
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}