summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/cobex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/cobex')
-rw-r--r--app-mobilephone/cobex/Manifest1
-rw-r--r--app-mobilephone/cobex/cobex-0.2.13.ebuild30
-rw-r--r--app-mobilephone/cobex/files/cobex-0.2.13-build.patch108
-rw-r--r--app-mobilephone/cobex/metadata.xml10
4 files changed, 149 insertions, 0 deletions
diff --git a/app-mobilephone/cobex/Manifest b/app-mobilephone/cobex/Manifest
new file mode 100644
index 000000000000..ab5155196bf1
--- /dev/null
+++ b/app-mobilephone/cobex/Manifest
@@ -0,0 +1 @@
+DIST cobex-0.2.13.tar.gz 27020 SHA256 7f840d59374b398891ed32c4de0eac0a7b71029eb38f658efe1590a685ca59ba SHA512 f05293d9d9f9fdf04809f2a5395bf8be3dd8bfbc592a9ca93b3b2e9b2a78157291b6d38e53b9c7f86e0e32567ee6d4028a9c48062eab4640c9cd85894e7e6a84 WHIRLPOOL 4573bc531a8791bea2856da4bc54b524454a3531a20a12062a5553877dcdcc716f98e0a6c842aa4eeab31f67d2ed9c79097dcfe4a6c52961f44d06e7a0dbdbad
diff --git a/app-mobilephone/cobex/cobex-0.2.13.ebuild b/app-mobilephone/cobex/cobex-0.2.13.ebuild
new file mode 100644
index 000000000000..3189dca6bbb2
--- /dev/null
+++ b/app-mobilephone/cobex/cobex-0.2.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="small implementation of Obex for phones using the DCU-11 USB-to-serial adapter"
+HOMEPAGE="http://cobex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cobex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/libezV24
+ dev-libs/expat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ local f
+ for f in get ls mkdir put rm ; do mv ${f}.c cobex_${f}.c || die ; done
+}
+
+src_install() {
+ dobin cobex_{ls,mkdir,put,rm} || die
+ dodoc Changelog README Things_to_know_T310.txt
+}
diff --git a/app-mobilephone/cobex/files/cobex-0.2.13-build.patch b/app-mobilephone/cobex/files/cobex-0.2.13-build.patch
new file mode 100644
index 000000000000..32ac20deb671
--- /dev/null
+++ b/app-mobilephone/cobex/files/cobex-0.2.13-build.patch
@@ -0,0 +1,108 @@
+--- Makefile
++++ Makefile
+@@ -1,75 +1,37 @@
+-CC=gcc
+-CCFLAGS=-O2 -Wall
+-EXTRACCFLAGS=-s -lezV24
+-EXPATCCFLAGS=-lexpat
+-CFILES=put.c get.c cobex_core.c ls.c cobex_tools.c cobex_serial.c rm.c mkdir.c
+-HFILES=cobex_defs.h cobex_core.h capabilities.h cobex_tools.h cobex_serial.h
+-O2FILES=cobex_core.o cobex_tools.o cobex_serial.o
+-PUTO=put.o
+-GETO=get.o
+-LSO=ls.o
+-RMO=rm.o
+-MKDIRO=mkdir.o
+-CAPAO=capability.o
+-COBEXPUT=cobex_put
+-COBEXGET=cobex_get
+-COBEXLS=cobex_ls
+-COBEXRM=cobex_rm
+-COBEXCAPA=cobex_capa
+-COBEXMKDIR=cobex_mkdir
++CC ?= gcc
++CFLAGS ?= -O2
++CFLAGS += -Wall
++LDLIBS += -lezV24
++
++PROGS = cobex_put cobex_get cobex_ls cobex_rm cobex_mkdir
++CFILES = $(wildcard *.c)
++HFILES = $(wildcard *.h)
++O2FILES = cobex_core.o cobex_tools.o cobex_serial.o
++
+ EXTRAFILES = README Changelog COPYING Makefile cobex_put.pl Things_to_know_T310.txt Hacking_pl2303_driver.txt
+ VERSION = 0.2.13
+ PROJNAME = cobex-$(VERSION)
+
+-all: $(COBEXPUT) $(COBEXGET) $(COBEXLS) $(COBEXRM) $(COBEXMKDIR)
++all: $(PROGS)
+
+ model:
+ cd modeldb && make all
+
+-$(COBEXPUT): $(O2FILES) $(PUTO)
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXPUT) $(PUTO) $(O2FILES)
+-
+-$(COBEXGET): $(O2FILES) $(GETO)
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXGET) $(GETO) $(O2FILES)
+-
+-$(COBEXRM): $(O2FILES) $(RMO)
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXRM) $(RMO) $(O2FILES)
+-
+-$(COBEXLS): $(O2FILES) $(LSO)
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) $(EXPATCCFLAGS) -o $(COBEXLS) $(LSO) $(O2FILES)
+-
+-$(COBEXCAPA): $(O2FILES) $(CAPAO)
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXCAPA) $(CAPAO) $(O2FILES)
+-
+-$(COBEXMKDIR): $(O2FILES) $(MKDIRO)
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXMKDIR) $(MKDIRO) $(O2FILES)
+-
+-
+-test2: $(O2FILES) test2.o
+- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) $(EXPATCCFLAGS) -o test2 test2.o $(O2FILES)
+-
+-.c.o:
+- $(CC) $(CCFLAGS) $(LOCKSERIAL) -c $<
+-
+-$(PUTO): put.c $(O2FILES)
+-
+-$(GETO): get.c $(O2FILES)
+-
+-$(LSO): ls.c $(O2FILES)
+-
+-$(RMO): rm.c $(O2FILES)
+-
+-test2.o: test2.c $(O2FILES)
+-
+-cobex_core.o: cobex_core.c cobex_core.h cobex_defs.h
+-
+-cobex_tools.o: cobex_tools.c cobex_tools.h cobex_defs.h cobex_core.c cobex_core.h
+-
+-cobex_serial.o: cobex_serial.c cobex_serial.h cobex_core.c cobex_core.h
++cobex_put: $(O2FILES)
++cobex_get: $(O2FILES)
++cobex_ls: $(O2FILES)
++cobex_rm: $(O2FILES)
++cobex_mkdir: $(O2FILES)
++cobex_capa: $(O2FILES)
++
++cobex_ls: LDLIBS += -lexpat
++
++-include .depend
++.depend: $(CFILES) $(HFILES)
++ $(CC) -MM $^ > .depend
+
+ clean:
+- rm -f *.o
+- cd modeldb && make clean
++ rm -f *.o $(PROGS)
+
+ printfiles: $(CFILES) $(HFILES)
+ @echo $?
+@@ -88,3 +50,5 @@
+
+ dist-contrib :
+ cd contrib && make dist VERSION=$(VERSION)
++
++.PHONY: all clean dist dist2 dist-modeldb dist-contrib model printfiles
diff --git a/app-mobilephone/cobex/metadata.xml b/app-mobilephone/cobex/metadata.xml
new file mode 100644
index 000000000000..802d259ce221
--- /dev/null
+++ b/app-mobilephone/cobex/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cobex</remote-id>
+ </upstream>
+</pkgmetadata>