summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:07 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:45 +0100
commit5d930c6dd1dbf098597702182f726d34ad6bfabd (patch)
tree038f968f8ab99a2cfc5bd4b66f71c22d61a1260c /dev-haskell/http-client
parentdev-haskell/http-client-tls: add 0.3.6.3 (diff)
downloadgentoo-5d930c6dd1dbf098597702182f726d34ad6bfabd.tar.gz
gentoo-5d930c6dd1dbf098597702182f726d34ad6bfabd.tar.bz2
gentoo-5d930c6dd1dbf098597702182f726d34ad6bfabd.zip
dev-haskell/http-client: add 0.7.14
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/http-client')
-rw-r--r--dev-haskell/http-client/Manifest1
-rw-r--r--dev-haskell/http-client/http-client-0.7.14.ebuild49
-rw-r--r--dev-haskell/http-client/metadata.xml1
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/http-client/Manifest b/dev-haskell/http-client/Manifest
index 3f4dec1cf8de..eda78e7fddff 100644
--- a/dev-haskell/http-client/Manifest
+++ b/dev-haskell/http-client/Manifest
@@ -1 +1,2 @@
DIST http-client-0.7.11.tar.gz 94548 BLAKE2B 5e630b5ec1861301a8a503238c111091b9b099d181b17a1d9c5fd22dac1dc60952faa7ec1da597dd909fe5f23408d728964461d77314a30a747e5edaa1757889 SHA512 0c01961e66c71636ff2628851151a788aaf941155d50a9f20b01a2e065ca7a8218ab4867b24e7cfb434aaa9b9178f727d950017870540e0bce91fffdcc374852
+DIST http-client-0.7.14.tar.gz 95406 BLAKE2B 9cb48fb44d529bc271ce969e72ff374c3d3afe1d983193e7ae7c55ea4dc8625df02e0a1ffd3597ef7882772a3f997057f88c37f356b088a8f9c2eeb9dcf90c7c SHA512 7668bb4b53c9d60aec3bb5a9342bb7c87502820d467dbf40943828136c52e99a619f0be6e8ec96fa6dcf79d8265b55fd3d681d5ce81f0e8540392534b26a3354
diff --git a/dev-haskell/http-client/http-client-0.7.14.ebuild b/dev-haskell/http-client/http-client-0.7.14.ebuild
new file mode 100644
index 000000000000..624051696f80
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.7.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.10-disable-net-tests.patch"
+)
+
+RDEPEND=">=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/iproute-1.7.5:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network-uri
+}
diff --git a/dev-haskell/http-client/metadata.xml b/dev-haskell/http-client/metadata.xml
index 895e9366e8a6..50f1751001a7 100644
--- a/dev-haskell/http-client/metadata.xml
+++ b/dev-haskell/http-client/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
+ <remote-id type="hackage">http-client</remote-id>
<remote-id type="github">snoyberg/http-client</remote-id>
</upstream>
</pkgmetadata>