summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/hamcrest-generator/hamcrest-generator-1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/hamcrest-generator/hamcrest-generator-1.1.ebuild')
-rw-r--r--dev-java/hamcrest-generator/hamcrest-generator-1.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/hamcrest-generator/hamcrest-generator-1.1.ebuild b/dev-java/hamcrest-generator/hamcrest-generator-1.1.ebuild
new file mode 100644
index 000000000000..9736c7f9c3d7
--- /dev/null
+++ b/dev-java/hamcrest-generator/hamcrest-generator-1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="hamcrest"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Code generator for Hamcrest's library of matchers for building test expressions"
+HOMEPAGE="http://code.google.com/p/${MY_PN}/"
+SRC_URI="http://${MY_PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+
+CDEPEND="dev-java/qdox:1.6"
+
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( sys-apps/findutils )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+EANT_BUILD_TARGET="generator"
+EANT_TEST_TARGET="unit-test"
+EANT_EXTRA_ARGS="-Dversion=${PV}"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/build/temp/${PN}-${PV}-nodeps.jar"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PV}-build.xml.patch
+
+ find -iname "*.jar" -exec rm -v {} + || die "Unable to remove bundled JAR files"
+
+ # These jars must be symlinked. Specifying them using gentoo.classpath
+ # does not work.
+ java-pkg_jar-from --into lib/generator qdox-1.6 qdox.jar qdox-1.6.1.jar
+}
+
+src_install() {
+ java-pkg_newjar build/temp/${PN}-${PV}-nodeps.jar ${PN}.jar
+
+ dodoc README.txt CHANGES.txt
+
+ use source && java-pkg_dosrc ${PN}/src/main/java/org
+}