summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/rundoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/rundoc')
-rw-r--r--dev-java/rundoc/Manifest1
-rw-r--r--dev-java/rundoc/metadata.xml12
-rw-r--r--dev-java/rundoc/rundoc-0.11.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/rundoc/Manifest b/dev-java/rundoc/Manifest
new file mode 100644
index 000000000000..2b1daada14cb
--- /dev/null
+++ b/dev-java/rundoc/Manifest
@@ -0,0 +1 @@
+DIST rundoc-0.11-src.tar.gz 26109 SHA256 e123a38260df24f7641c3c0b5164be810ba6770d14d546d60b09a55e86333bc1 SHA512 e27f4f6ecbb4a78bc8ed245829e0ab7d727166890bfd4f55d544d4073f20691681bcb223e5cd353f786e79fc446bee24f10d955ed9844a44dd610b7eb7b773d4 WHIRLPOOL 5edd6a1b8b2865b60e82b3bd41640591919079f85283581343c1069c934edc0236a5e9a73683401618e6862abd892aaf9c0094711a04e7c8d8e2ac552ca2acb7
diff --git a/dev-java/rundoc/metadata.xml b/dev-java/rundoc/metadata.xml
new file mode 100644
index 000000000000..1eee4a6024e9
--- /dev/null
+++ b/dev-java/rundoc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+
+ <longdescription lang="en">
+ rundoc is an Ant task designed to help with the single-sourcing of
+ program documentation. This task replaces special commands embedded
+ within text files with their output in a specified format. Currently,
+ only docbook format is supported.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-java/rundoc/rundoc-0.11.ebuild b/dev-java/rundoc/rundoc-0.11.ebuild
new file mode 100644
index 000000000000..4c5cc4de1976
--- /dev/null
+++ b/dev-java/rundoc/rundoc-0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Ant helper task for keeping documentation in source files"
+HOMEPAGE="http://www.martiansoftware.com/lab/index.html"
+SRC_URI="http://www.martiansoftware.com/lab/${PN}/${P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEP=">=dev-java/ant-core-1.5.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -v *.jar
+ java-ant_rewrite-classpath
+}
+
+EANT_GENTOO_CLASSPATH="ant-core"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar
+
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/java/com
+}