summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-16 11:31:42 +0100
committerSam James <sam@gentoo.org>2021-10-16 11:31:42 +0100
commita491173ff44e4981d6cdaf9f0856cb23a45393ec (patch)
tree9d2a7d91951cba05733da2f51daf870f451ccffa /dev-lang
parentdev-lang/ocaml: filter LTO, no strict aliasing in <4.12 (diff)
downloadgentoo-a491173ff44e4981d6cdaf9f0856cb23a45393ec.tar.gz
gentoo-a491173ff44e4981d6cdaf9f0856cb23a45393ec.tar.bz2
gentoo-a491173ff44e4981d6cdaf9f0856cb23a45393ec.zip
dev-lang/ocaml: filter -flto* too
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r7.ebuild2
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r8.ebuild2
-rw-r--r--dev-lang/ocaml/ocaml-4.09.0-r2.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-4.10.2-r2.ebuild2
-rw-r--r--dev-lang/ocaml/ocaml-4.11.2-r2.ebuild2
5 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
index 9ef969d018ba..68a369bcebf8 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
@@ -68,7 +68,7 @@ src_configure() {
# Broken until 4.12
# bug #818445
- filter-flags -flto
+ filter-flags '-flto*'
append-flags -fno-strict-aliasing
# -ggdb3 & co makes it behave weirdly, breaks sexplib
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
index 707f584fb231..4c2da17dac59 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
@@ -69,7 +69,7 @@ src_configure() {
# Broken until 4.12
# bug #818445
- filter-flags -flto
+ filter-flags '-flto*'
append-flags -fno-strict-aliasing
# -ggdb3 & co makes it behave weirdly, breaks sexplib
diff --git a/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
index b9f00b2cfe03..68b58ca86b18 100644
--- a/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
@@ -21,7 +21,7 @@ BDEPEND="${RDEPEND}
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
-PATCHES=("${FILESDIR}"/${PN}-4.09.0-gcc-10.patch)
+PATCHES=( "${FILESDIR}"/${PN}-4.09.0-gcc-10.patch )
src_prepare() {
default
@@ -30,7 +30,7 @@ src_prepare() {
# Broken until 4.12
# bug #818445
- filter-flags -flto
+ filter-flags '-flto*'
append-flags -fno-strict-aliasing
# OCaml generates textrels on 32-bit arches
diff --git a/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
index 69ae1931963a..3b6334a9c87c 100644
--- a/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
@@ -28,7 +28,7 @@ src_prepare() {
# Broken until 4.12
# bug #818445
- filter-flags -flto
+ filter-flags '-flto*'
append-flags -fno-strict-aliasing
# OCaml generates textrels on 32-bit arches
diff --git a/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
index 001fbf26fdf9..e965a0afa51b 100644
--- a/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
@@ -28,7 +28,7 @@ src_prepare() {
# Broken until 4.12
# bug #818445
- filter-flags -flto
+ filter-flags '-flto*'
append-flags -fno-strict-aliasing
# OCaml generates textrels on 32-bit arches