summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 18:11:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 18:11:29 +0100
commit6ad66dc8a702af7da08ab8d07656a21679ef749d (patch)
tree5c74083d625026abd00bf4672b72d04632434d25 /dev-python/astunparse
parentpackage.mask: Last rite dev-python/alagitpull (diff)
downloadgentoo-6ad66dc8a702af7da08ab8d07656a21679ef749d.tar.gz
gentoo-6ad66dc8a702af7da08ab8d07656a21679ef749d.tar.bz2
gentoo-6ad66dc8a702af7da08ab8d07656a21679ef749d.zip
dev-python/astunparse: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astunparse')
-rw-r--r--dev-python/astunparse/astunparse-1.6.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/astunparse/astunparse-1.6.3-r1.ebuild b/dev-python/astunparse/astunparse-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..eccebf021ee7
--- /dev/null
+++ b/dev-python/astunparse/astunparse-1.6.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astun parser for python"
+HOMEPAGE="
+ https://github.com/simonpercivall/astunparse/
+ https://pypi.org/project/astunparse/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.23.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/astunparse-1.6.2-tests.patch"
+ # from Fedora
+ "${FILESDIR}/${P}-py39.patch"
+)
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc *.rst
+}