summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-23 10:12:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-23 10:12:26 +0300
commit0e5347e6b3e6d2ac0af7777dfb010368a78dcd06 (patch)
tree5bfdad2013e185511184384fad4962d7d4e18772 /dev-python/doit
parentdev-python/Faker: add 13.4.0 (diff)
downloadgentoo-0e5347e6b3e6d2ac0af7777dfb010368a78dcd06.tar.gz
gentoo-0e5347e6b3e6d2ac0af7777dfb010368a78dcd06.tar.bz2
gentoo-0e5347e6b3e6d2ac0af7777dfb010368a78dcd06.zip
dev-python/doit: add 0.36.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest1
-rw-r--r--dev-python/doit/doit-0.36.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index a5dc1661ea51..2e24afb4ea79 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,2 +1,3 @@
DIST doit-0.34.2.tar.gz 1449767 BLAKE2B c7d81144da99147dbc6bf7d670b6f411879a8080e405866866bc97ae4701d9a47a3d4882db9672e2e36bc8af577ba9632da1fb4ed2c9f87717f719ac1cd53d34 SHA512 24afc8078fef42a446733554c6ab63298ee5bb734381fc2bfc9d623dc98394916a1f89a18bb28e7ef862da8c0449b5cf16d605295e8948a0ea6968a231a1c8e2
DIST doit-0.35.0.tar.gz 1451502 BLAKE2B db0c1c9245897ca9c4ce4d3f5f43e5f2e5035c36cc4bd15e63d6fb9e69992b5068ca24839a02485680cdc75ba62cb95f139f6fd0ec24c1f26fd4c4b2e4fce27e SHA512 3eb3fc0284c4779db47c56c9e21bda16e31d053214f4a0272c1a26c9fd26bc0de7d00601bb08a79a3d0ed403464e773c03fe93d0fcd9ee59812c396e0f4ed7e6
+DIST doit-0.36.0.tar.gz 1448096 BLAKE2B 15558a39ccac031ddf3a429aa585bc6e1d49c2e7572df29979ca66d1025fa5d7a917f6cc5bcfd21f2749e4ed7e7885b0865ec67b6fa32817e1518d47da9ead97 SHA512 d4caa31701755c7f59213dde0f89fd3616c0c01b7f06245cbfd9f1a315d503e62f3556c3b86685cd0ebfcffcc9cae0987ca150f037aa7b3cd960439a1191be42
diff --git a/dev-python/doit/doit-0.36.0.ebuild b/dev-python/doit/doit-0.36.0.ebuild
new file mode 100644
index 000000000000..e705518faed6
--- /dev/null
+++ b/dev-python/doit/doit-0.36.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="https://pydoit.org/
+ https://pypi.org/project/doit/
+ https://github.com/pydoit/doit"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ || (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # test failing due to impact on PATH run in a sandbox
+ tests/test_cmd_strace.py::TestCmdStrace::test_target
+)
+
+src_prepare() {
+ # Replace custom theme with builtin for documentation
+ sed -e '/html_theme/s/press/sphinx_rtd_theme/' -i doc/conf.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp bash_completion_doit ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins zsh_completion_doit _${PN}
+}