summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-02 12:39:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-02 12:43:56 +0100
commit8cae5db205ea8329aa886de50486272249e3df1a (patch)
treeca3bbc0b92717b1e2e52bfc21ea055785a9a49ec /dev-python/fakeredis
parentdev-python/responses: Remove old (diff)
downloadgentoo-8cae5db205ea8329aa886de50486272249e3df1a.tar.gz
gentoo-8cae5db205ea8329aa886de50486272249e3df1a.tar.bz2
gentoo-8cae5db205ea8329aa886de50486272249e3df1a.zip
dev-python/fakeredis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.21.0.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index db43b804db6e..252676a997db 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,2 +1 @@
-DIST fakeredis-2.21.0.tar.gz 128492 BLAKE2B a7352e1518a23512c8410ab199effffcea5beb28b93162d71ea95551a9267441c5487e676372951c950401dcb4003f066e80a03521ab2176059409c487a60a2e SHA512 5ef46fcd16e5347cb6a4ef1f99140385ed0d1809ab584df952e3050e4f115b34b37387efb7d01521d433a32262e0729eef266a98b1d1ff46250b4545052e0a9e
DIST fakeredis-2.21.1.tar.gz 128540 BLAKE2B 042c7189f4437149f099eb2bed9dc93cfaea3eb582dd40aaad55bca6c6c4f679a108b3e36006e537be469a3879085f75e0f5c0c7272d2131c431a4483e15cefc SHA512 ba51079896ca345805a0b2474922a41b7c1526123ac3ff0904d3448512b75515b6b11d7e8ec8fe7abdde94a9ac281aaf56d7344809c18c28ad081af4a542a57b
diff --git a/dev-python/fakeredis/fakeredis-2.21.0.ebuild b/dev-python/fakeredis/fakeredis-2.21.0.ebuild
deleted file mode 100644
index d0865eabf695..000000000000
--- a/dev-python/fakeredis/fakeredis-2.21.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/cunla/fakeredis-py/
- https://pypi.org/project/fakeredis/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/redis-4.2[${PYTHON_USEDEP}]
- <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # also lupa
- test/test_aioredis2.py::test_failed_script_error
- # TODO
- "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
- "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
- "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
- "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
- test/test_mixins/test_set_commands.py::test_smismember_wrong_type
- # new redis-server?
- "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
- # json ext
- test/test_json/test_json.py
- test/test_json/test_json_arr_commands.py
- )
- local EPYTEST_IGNORE=(
- # these tests fail a lot...
- test/test_hypothesis.py
- )
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- # Note: this package is not xdist-friendly
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}