summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-12 13:09:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-12 13:37:38 +0200
commit26663da96c4a8ab02a07191e76fe11d55bd1a387 (patch)
tree50d8cd82671ef4687d706165198a29c7068a8797 /dev-python/openapi-spec-validator
parentdev-python/cssutils: Bump to 2.7.1 (diff)
downloadgentoo-26663da96c4a8ab02a07191e76fe11d55bd1a387.tar.gz
gentoo-26663da96c4a8ab02a07191e76fe11d55bd1a387.tar.bz2
gentoo-26663da96c4a8ab02a07191e76fe11d55bd1a387.zip
dev-python/openapi-spec-validator: Bump to 0.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest1
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.5.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index c9f626e1bfa8..ee8389786b3d 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1 +1,2 @@
DIST openapi_spec_validator-0.5.6.tar.gz 33031 BLAKE2B a884ceb915f232232406bd880a7eef9e588e1a42ac9a78c2e23f91cbd71e9af471c764550a9dd214ef68ec24ede7ab0ba4624429e4fd8133011489d0039aeae7 SHA512 ea1e810ecf49ff3d237e3368cd2cbcc6b733e9657f101759860ef16d3e2f14c97ccfe52fae2897d12a50c803d709d61d7ef8b40b288e5f73265da9ac5c88280b
+DIST openapi_spec_validator-0.5.7.tar.gz 33722 BLAKE2B 71096a996d335b60d6646d96390e580952a1e27829aa807c4b333ee11a7925bc1bc10f4440c79fc6d4a8321dfd3bab9ec86bf79bef6c7139835b7f8035cbc061 SHA512 63dafc0bc459d8ad097d0a98a3d23e67ae37c0004ce6d53ad999b037f2a6743c95e13ae22920403368c37f8877665c104ac20e1f58532cffd8df54c800a6cf7d
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.7.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.7.ebuild
new file mode 100644
index 000000000000..42b40945683f
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.5.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/jsonschema-4.18[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}