summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pika
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pika')
-rw-r--r--dev-python/pika/Manifest1
-rw-r--r--dev-python/pika/metadata.xml14
-rw-r--r--dev-python/pika/pika-0.9.14.ebuild20
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pika/Manifest b/dev-python/pika/Manifest
new file mode 100644
index 000000000000..ca37cd4ed5de
--- /dev/null
+++ b/dev-python/pika/Manifest
@@ -0,0 +1 @@
+DIST pika-0.9.14.tar.gz 72651 SHA256 5e2be3cb4ebdc267abd8e481c09bc30e95919a24e3a5f3f69744959490ead0e3 SHA512 c5b279c48341cef7b86d11414159de778afd3cf043d0ba8ba45adff6e8fbf72ec39642ed533c4d3674df3555fdaa0d7ff32a1844001bc56c1c380643d075870c WHIRLPOOL 3f73bbf4b892b9f60a5c113dd65027103de84578cad895b306fcff9ec02861429d4e32a8ba4a22f5def2a1030e8f10dceffb8f9c715d3bb845394fe012c6808f
diff --git a/dev-python/pika/metadata.xml b/dev-python/pika/metadata.xml
new file mode 100644
index 000000000000..a0484b5114c6
--- /dev/null
+++ b/dev-python/pika/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>Pika is a pure-Python implementation of the AMQP 0-9-1 protocol that tries to stay fairly independent of the underlying network support library. Pika was developed primarily for use with RabbitMQ, but should also work with other AMQP 0-9-1 brokers.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pika</remote-id>
+ <remote-id type="github">pika/pika</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pika/pika-0.9.14.ebuild b/dev-python/pika/pika-0.9.14.ebuild
new file mode 100644
index 000000000000..26dee82841c3
--- /dev/null
+++ b/dev-python/pika/pika-0.9.14.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the AMQP"
+HOMEPAGE="https://pika.readthedocs.org/ https://github.com/pika/pika"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""