summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 18:22:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 18:40:44 +0200
commit295027ec12b5b70aea700fbc50e1cd87a0aedf02 (patch)
tree2722e11db0acfa2c5a0fe83ce2a4ff53a2cdc7dd /dev-python/poetry-plugin-export/poetry-plugin-export-1.5.0.ebuild
parentdev-python/poetry-core: Bump to 1.7.0 (diff)
downloadgentoo-295027ec12b5b70aea700fbc50e1cd87a0aedf02.tar.gz
gentoo-295027ec12b5b70aea700fbc50e1cd87a0aedf02.tar.bz2
gentoo-295027ec12b5b70aea700fbc50e1cd87a0aedf02.zip
dev-python/poetry-plugin-export: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry-plugin-export/poetry-plugin-export-1.5.0.ebuild')
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.5.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.5.0.ebuild
new file mode 100644
index 000000000000..b69f11168144
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.6.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest