summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 17:58:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 18:03:11 +0200
commite87eca5be086096509865d7dc17a576bd6860e5e (patch)
tree70b653bde73af66e9845a0cd01535ae6f3391e35 /dev-python/pyqt-distutils
parentnet-irc/limnoria: Enable py3.11 (diff)
downloadgentoo-e87eca5be086096509865d7dc17a576bd6860e5e.tar.gz
gentoo-e87eca5be086096509865d7dc17a576bd6860e5e.tar.bz2
gentoo-e87eca5be086096509865d7dc17a576bd6860e5e.zip
dev-python/pyqt-distutils: EAPI 8, PEP517, py3.11
Closes: https://bugs.gentoo.org/896840 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyqt-distutils')
-rw-r--r--dev-python/pyqt-distutils/Manifest1
-rw-r--r--dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyqt-distutils/Manifest b/dev-python/pyqt-distutils/Manifest
index debb05053814..28c3bc54ffda 100644
--- a/dev-python/pyqt-distutils/Manifest
+++ b/dev-python/pyqt-distutils/Manifest
@@ -1 +1,2 @@
DIST pyqt-distutils-0.7.3.gh.tar.gz 16628 BLAKE2B 0d9d7f951890c00efd95bf3caef8c8964d02f3097840f84006a8d9523c0ad9b78dbb5f46c4d752945074ba971c92e81e81be0345b7a8c807932e7157ecd00e03 SHA512 450569be205aa0de792c3f2d8c43e26eb6fed1088b241291347ae14d2343b61517bd7547f741bd62bb9e1bfb92077d1ae5c64b871c39d59a67ca82172ac1c598
+DIST pyqt_distutils-0.7.3.gh.tar.gz 16628 BLAKE2B 0d9d7f951890c00efd95bf3caef8c8964d02f3097840f84006a8d9523c0ad9b78dbb5f46c4d752945074ba971c92e81e81be0345b7a8c807932e7157ecd00e03 SHA512 450569be205aa0de792c3f2d8c43e26eb6fed1088b241291347ae14d2343b61517bd7547f741bd62bb9e1bfb92077d1ae5c64b871c39d59a67ca82172ac1c598
diff --git a/dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..f827f8f052b6
--- /dev/null
+++ b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="distutils extension to work with PyQt applications and UI files"
+HOMEPAGE="
+ https://github.com/ColinDuquesnoy/pyqt_distutils/
+ https://pypi.org/project/pyqt-distutils/
+"
+SRC_URI="
+ https://github.com/ColinDuquesnoy/pyqt_distutils/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest