summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 09:32:31 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 11:35:48 +0100
commit1958cac119e6b93283b7997f301eb3a015ad5021 (patch)
treedc5d98d95578a3a33440c0f961eba69d58d1bfef /dev-python/pytest-forked
parentdev-python/pytest-forked: Fix MissingTestRestrict (diff)
downloadgentoo-1958cac119e6b93283b7997f301eb3a015ad5021.tar.gz
gentoo-1958cac119e6b93283b7997f301eb3a015ad5021.tar.bz2
gentoo-1958cac119e6b93283b7997f301eb3a015ad5021.zip
dev-python/pytest-forked: Bump to 1.1.3, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/Manifest1
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.1.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index c1228dfa3d36..23d46b6cb660 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1 +1,2 @@
DIST pytest-forked-0.2.tar.gz 9617 BLAKE2B f306c968447b73ddd606f7929b730d222f30640544ff89f6e3e2171ec3b0e98877e0263fea6564d943789de6daa1c344022f001ef80ca37b2467c1b9c360eed7 SHA512 5e84fcaceed46ee9da8eec051e72acb46f09e2df3458511651604c35d68e3ad06fc41d52578127fd29f0c216dcb5fce1844c614f10501727cbf8fa8f2316f231
+DIST pytest-forked-1.1.3.tar.gz 7308 BLAKE2B 70711228a5a815de23cbd07b2b628e336a26ccecf420dc9d30d9e9b7ed33bc362b0ba74a8f90fb7cb8dc9e7e0f61d2ac22da55584a84e8ac3a26fcfc2878a802 SHA512 2086884b0e78841b3cdf8eb2b144b8fa60ba95e4be79bc58a2b5775a5f997dddef59377f7c993e54974fbbe13e73fe8688eed4d035e85293e35a143c5f0180f3
diff --git a/dev-python/pytest-forked/pytest-forked-1.1.3.ebuild b/dev-python/pytest-forked/pytest-forked-1.1.3.ebuild
new file mode 100644
index 000000000000..49d7af7dc865
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv -p no:flaky || die "Tests failed under ${EPYTHON}"
+}