summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-16 09:32:50 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-16 09:32:50 -0600
commit5314f05d2c61550de3735edf00cb86d5f52e1164 (patch)
tree981a54fd47b5b1b9d84e32429a2ce4fcb00806a3 /dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild
parentdev-python/oslo-messaging: Block kombu 4.0.0 (diff)
downloadgentoo-5314f05d2c61550de3735edf00cb86d5f52e1164.tar.gz
gentoo-5314f05d2c61550de3735edf00cb86d5f52e1164.tar.bz2
gentoo-5314f05d2c61550de3735edf00cb86d5f52e1164.zip
dev-python/python-ceilometerclient: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild')
-rw-r--r--dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild
new file mode 100644
index 000000000000..fae8f4ce393b
--- /dev/null
+++ b/dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API"
+HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ <dev-python/fixtures-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.1.0
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2.7"
+ flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
+}