summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-25 18:39:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-25 18:41:45 +0100
commite3477960643e8c85cd884168ae9ff95374fe1fe5 (patch)
tree45eda556d7e472f0dbb9c9cf705e42deb3e843c9 /dev-python/rpyc
parentdev-python/python-nbxmpp: Remove old (diff)
downloadgentoo-e3477960643e8c85cd884168ae9ff95374fe1fe5.tar.gz
gentoo-e3477960643e8c85cd884168ae9ff95374fe1fe5.tar.bz2
gentoo-e3477960643e8c85cd884168ae9ff95374fe1fe5.zip
dev-python/rpyc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest1
-rw-r--r--dev-python/rpyc/rpyc-5.2.3-r3.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 34507ef27231..4f77b1578c88 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,2 +1 @@
-DIST rpyc-5.2.3.tar.gz 1267934 BLAKE2B 3c03d587293375f875de31d6a89ba07b47bd4f4ff9fd5c7b23ed0c83e420e9d2bab08844c3538299797203ac90e7e81b955db02de70bf1cee5ea59d8475a6848 SHA512 4be189a719be100886e08d9c2c0769d12b7d1c5e167c197ebee1a3db542e228f2124fea976e5af3680136b298ce4632c79b2f302128dff31ebf45dcf52a9743f
DIST rpyc-5.2.3_p1.tar.gz 1269198 BLAKE2B 288568fcd34787850968d4e3fd9ca7c2d29e506f1331b746104760e678dfef43fd30b08f68b3bdda6df84d488f88dc76cfdd23d5a5ad0a4cefeab468ac6a1b0b SHA512 4b29899a51364779185d2b56f5d5ee4c650c40b8322e5594500222fdcec85414cdbabd41437467e2ff73124a79e8c9cde23dfe89138abb935732ccaba69de2bb
diff --git a/dev-python/rpyc/rpyc-5.2.3-r3.ebuild b/dev-python/rpyc/rpyc-5.2.3-r3.ebuild
deleted file mode 100644
index 22aea49bdb94..000000000000
--- a/dev-python/rpyc/rpyc-5.2.3-r3.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{8..10} )
-# Teleporting currently does not work with python-3.11
-# see https://github.com/tomerfiliba-org/rpyc/issues/513
-
-inherit distutils-r1
-
-DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
-HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
- https://pypi.org/project/rpyc/
- https://github.com/tomerfiliba-org/rpyc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# USE flags gdb, numpy are used *only* to run tests depending on these packages
-IUSE="test numpy gdb"
-RESTRICT="!test? ( test )"
-
-CDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
- gdb? ( sys-devel/gdb )"
-
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="${CDEPEND}
- dev-python/plumbum[${PYTHON_USEDEP}]"
-
-src_prepare() {
- default
-
- # Windows specific test
- rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
-
- # These tests require running sshd
- rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
-
- # This test requires internet access
- rm tests/test_registry.py || die "rm test_registry.py failed"
-
- # This test fails with NO_CIPHERS_AVAILABLE
- rm tests/test_ssl.py || die "rm test_ssl.py failed"
-
- if ! use numpy
- then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
- fi
-
- rm tests/test_gevent_server.py || die "rm test_gevent_server.py failed"
-
- if ! use gdb
- then rm tests/test_gdb.py || die "rm test_gdb.py failed"
- fi
-}
-
-python_test() {
- # for some reason, when tests are run via pytest or nose, some of them hung
- pushd tests > /dev/null || die "pushd tests failed"
- for x in test_*.py
- do PYTHONPATH="${WORKDIR}"/${P}-${EPYTHON/./_}/install/usr/lib/${EPYTHON}/site-packages ${EPYTHON} ${x} || die "${x} failed"
- done
- popd > /dev/null
-}