summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-17 11:35:25 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-17 11:35:25 +0100
commit8065e6dcc5cdf0bcf2ee01236613bfd76e2ac641 (patch)
tree06ef210d1aaf6e61ad3d86d10ba8966ec4f93e2f /dev-python/spyder-line-profiler
parentgames-util/lutris: drop dependency on net-libs/libsoup (diff)
downloadgentoo-8065e6dcc5cdf0bcf2ee01236613bfd76e2ac641.tar.gz
gentoo-8065e6dcc5cdf0bcf2ee01236613bfd76e2ac641.tar.bz2
gentoo-8065e6dcc5cdf0bcf2ee01236613bfd76e2ac641.zip
dev-python/spyder-line-profiler: enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-line-profiler')
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..6f07c443f2d4
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}