summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-22 03:00:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-22 03:00:05 +0100
commite86acddf4fa2e8e780583a7660942b05b066d2a6 (patch)
tree450a4cf5cbd5f62fd3c36f1676e77fbf83b17278 /dev-ruby/prawn
parentdev-ruby/pdf-core: Add ruby23, drop ~ia64, ~ppc, ~sparc keywords (diff)
downloadgentoo-e86acddf4fa2e8e780583a7660942b05b066d2a6.tar.gz
gentoo-e86acddf4fa2e8e780583a7660942b05b066d2a6.tar.bz2
gentoo-e86acddf4fa2e8e780583a7660942b05b066d2a6.zip
dev-ruby/prawn: Add ruby23, drop ~ia64, ~ppc, ~sparc keywords
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/prawn')
-rw-r--r--dev-ruby/prawn/prawn-2.1.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/prawn/prawn-2.1.0-r1.ebuild b/dev-ruby/prawn/prawn-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..e780e64ec64f
--- /dev/null
+++ b/dev-ruby/prawn/prawn-2.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pdf-core-0.6.1
+ >=dev-ruby/ttfunk-1.4.0"
+ruby_add_bdepend "test? ( dev-ruby/coderay
+ >=dev-ruby/pdf-inspector-1.2.1
+ >=dev-ruby/pdf-reader-1.2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile spec/spec_helper.rb || die
+ # Remove failing tests
+ # https://github.com/prawnpdf/prawn/pull/693
+ # https://github.com/prawnpdf/prawn/issues/603
+ sed -i -e "/should process UTF-8 chars/,+9 s/^/#/" spec/line_wrap_spec.rb || die
+ sed -i -e "/shrink_to_fit with special utf-8 text/,+12 s/^/#/" spec/text_spec.rb || die
+}