summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-15 07:03:36 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-15 07:03:36 +0100
commit3115e542f8de7438b94e9774f8ce1a1be5346c88 (patch)
tree449a3b4e517f1a503f2c8c7434b01cdbd387b94d /dev-ruby/tty-prompt/tty-prompt-0.23.0.ebuild
parentdev-ruby/ruby-termios: add 1.1.0 (diff)
downloadgentoo-3115e542f8de7438b94e9774f8ce1a1be5346c88.tar.gz
gentoo-3115e542f8de7438b94e9774f8ce1a1be5346c88.tar.bz2
gentoo-3115e542f8de7438b94e9774f8ce1a1be5346c88.zip
dev-ruby/tty-prompt: add 0.23.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-prompt/tty-prompt-0.23.0.ebuild')
-rw-r--r--dev-ruby/tty-prompt/tty-prompt-0.23.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.23.0.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.23.0.ebuild
new file mode 100644
index 000000000000..86c2dc4efca8
--- /dev/null
+++ b/dev-ruby/tty-prompt/tty-prompt-0.23.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-prompt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A beautiful and powerful interactive command line prompt"
+HOMEPAGE="https://github.com/piotrmurach/tty-prompt"
+SRC_URI="https://github.com/piotrmurach/tty-prompt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/pastel-0.8:0
+ >=dev-ruby/tty-reader-0.8:0
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}