summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-07-14 13:50:52 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-07-14 13:52:30 -0500
commit0d972f0995b2f61fdbd82b2df2f0562df5fd50d3 (patch)
tree013f62e167707a29f860b06643541027edde54cb /dev-util/mage/mage-1.11.0.ebuild
parentdev-perl/Gtk3-ImageView: add upstream meta (diff)
downloadgentoo-0d972f0995b2f61fdbd82b2df2f0562df5fd50d3.tar.gz
gentoo-0d972f0995b2f61fdbd82b2df2f0562df5fd50d3.tar.bz2
gentoo-0d972f0995b2f61fdbd82b2df2f0562df5fd50d3.zip
dev-util/mage: new package, make/rake like tool using go
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/mage/mage-1.11.0.ebuild')
-rw-r--r--dev-util/mage/mage-1.11.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/mage/mage-1.11.0.ebuild b/dev-util/mage/mage-1.11.0.ebuild
new file mode 100644
index 000000000000..b589b5b0780b
--- /dev/null
+++ b/dev-util/mage/mage-1.11.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="make/rake like tool using go"
+HOMEPAGE="https://magefile.org"
+SRC_URI="https://github.com/magefile/mage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ GOBIN="${S}/bin" go run bootstrap.go || die "build failed"
+}
+
+src_install() {
+dobin bin/mage
+}