summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/qbzr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/qbzr')
-rw-r--r--dev-vcs/qbzr/Manifest2
-rw-r--r--dev-vcs/qbzr/metadata.xml8
-rw-r--r--dev-vcs/qbzr/qbzr-0.23.0.ebuild46
-rw-r--r--dev-vcs/qbzr/qbzr-0.23.1.ebuild43
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-vcs/qbzr/Manifest b/dev-vcs/qbzr/Manifest
new file mode 100644
index 000000000000..ea7b4687ff6f
--- /dev/null
+++ b/dev-vcs/qbzr/Manifest
@@ -0,0 +1,2 @@
+DIST qbzr-0.23.0.tar.gz 808036 SHA256 7e66f2cdb3b38e83ecb99ae2934fe42e9c137273a06d54f66aa76da8a06bef58 SHA512 c1f26ef0db8db48e5b05cb6164bac08f33746983df85dba9e359a78dffbf05f18f67788f0d0e7b42deb530cf5a31cd9284752946ee00731c1e7559a0dcc4a071 WHIRLPOOL f925a7d49fc6f8702a921731090abd44192ab88a9a1c28d1e37d7ea94fc1550a13c0c7204f0328225bd71c481653afd7846e2b92401e2de246f7b2753baffa81
+DIST qbzr-0.23.1.tar.gz 817769 SHA256 3211adef11c975dfbb6c80285651e2e6f3bfa99f1baa1a95371e8490ea8ff441 SHA512 05d05c2cf5e94d4a58d88d04bd3dd4ff13d977126d728683273990801733bc0dfb07388838e466117961a83c6e08454b7a8bdaca975ca19f7ecff729d97b4bd2 WHIRLPOOL 359f23ccaee972652c535ca238e7ee1a6781b5bc348aa291105bc1bb1211c98b2ebdf78d81d89659d6ff8c523ee3fcea9102a3a83f18c3e0a5b677b304a739b2
diff --git a/dev-vcs/qbzr/metadata.xml b/dev-vcs/qbzr/metadata.xml
new file mode 100644
index 000000000000..b5b93b4d45d9
--- /dev/null
+++ b/dev-vcs/qbzr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bazaar</herd>
+ <upstream>
+ <remote-id type="launchpad">qbzr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/qbzr/qbzr-0.23.0.ebuild b/dev-vcs/qbzr/qbzr-0.23.0.ebuild
new file mode 100644
index 000000000000..26a055787068
--- /dev/null
+++ b/dev-vcs/qbzr/qbzr-0.23.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils versionator
+
+DESCRIPTION="Qt frontend for Bazaar"
+HOMEPAGE="https://launchpad.net/qbzr"
+SRC_URI="https://edge.launchpad.net/qbzr/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+# bzr version comes from NEWS file. It's lowest version required for some
+# features to work.
+DEPEND=">=dev-vcs/bzr-2.5
+ >=dev-python/PyQt4-4.1[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="AUTHORS.txt NEWS.txt README.txt TODO.txt"
+PYTHON_MODNAME="bzrlib/plugins/qbzr"
+
+src_test() {
+ elog "It's impossible to run tests at this point. If you wish to run tests"
+ elog "after installation of ${PN} execute:"
+ elog " $ bzr selftest -s bzrlib.plugins.qbzr"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog
+ elog "To enable spellchecking in qcommit, please, install >=dev-python/pyenchant-1.5.0"
+ elog " # emerge -a >=dev-python/pyenchant-1.5.0"
+ elog "To enable syntax highlighting, please, install dev-python/pygments"
+ elog " # emerge -a dev-python/pygments"
+}
diff --git a/dev-vcs/qbzr/qbzr-0.23.1.ebuild b/dev-vcs/qbzr/qbzr-0.23.1.ebuild
new file mode 100644
index 000000000000..87bbc46126eb
--- /dev/null
+++ b/dev-vcs/qbzr/qbzr-0.23.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Qt frontend for Bazaar"
+HOMEPAGE="https://launchpad.net/qbzr"
+SRC_URI="https://edge.launchpad.net/qbzr/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+# bzr version comes from NEWS file. It's lowest version required for some
+# features to work.
+DEPEND=">=dev-vcs/bzr-2.5
+ >=dev-python/PyQt4-4.1[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS.txt NEWS.txt README.txt TODO.txt )
+
+src_test() {
+ elog "It's impossible to run tests at this point. If you wish to run tests"
+ elog "after installation of ${PN} execute:"
+ elog " $ bzr selftest -s bzrlib.plugins.qbzr"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog
+ elog "To enable spellchecking in qcommit, please, install >=dev-python/pyenchant-1.5.0"
+ elog " # emerge -a >=dev-python/pyenchant-1.5.0"
+ elog "To enable syntax highlighting, please, install dev-python/pygments"
+ elog " # emerge -a dev-python/pygments"
+}