summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 21:10:18 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:31 +0200
commita10b3dddad73f92c3d3fabef338e374ef6dfd7d8 (patch)
tree87843a1e6cc1bfd327b86d0ca097ad3100b3f721 /games-arcade/vor
parentgames-arcade/tuxpuck: Drop old (diff)
downloadgentoo-a10b3dddad73f92c3d3fabef338e374ef6dfd7d8.tar.gz
gentoo-a10b3dddad73f92c3d3fabef338e374ef6dfd7d8.tar.bz2
gentoo-a10b3dddad73f92c3d3fabef338e374ef6dfd7d8.zip
games-arcade/vor: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/vor')
-rw-r--r--games-arcade/vor/vor-0.5.7-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-arcade/vor/vor-0.5.7-r1.ebuild b/games-arcade/vor/vor-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..67a35306efe8
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop gnome2-utils
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="http://jasonwoof.org/vor"
+SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /usr/bin
+ DOCS="README* todo" default
+ newicon -s 48 data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}