summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-08 11:38:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-08 11:54:26 +0200
commitb1a7d2251f1ce089d554d2872c5f3570879527e2 (patch)
tree665d2feb5748628aeed78f774f61a00f0a917b58 /games-emulation
parentgames-emulation/dolphin: Update HOMEPAGE (diff)
downloadgentoo-b1a7d2251f1ce089d554d2872c5f3570879527e2.tar.gz
gentoo-b1a7d2251f1ce089d554d2872c5f3570879527e2.tar.bz2
gentoo-b1a7d2251f1ce089d554d2872c5f3570879527e2.zip
games-emulation/dolphin: Fix LICENSE
Adjust the package's license to GPL-2+, plus add licenses for the bundled deps. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild76
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild82
2 files changed, 81 insertions, 77 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
index 28d9f08814fa..994989ac1a82 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506-r1.ebuild
@@ -21,7 +21,8 @@ fi
DESCRIPTION="Gamecube and Wii game emulator"
HOMEPAGE="https://dolphin-emu.org/"
-LICENSE="GPL-2"
+# NB: appended below
+LICENSE="GPL-2+"
SLOT="0"
IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg +gui log
profile pulseaudio systemd upnp vulkan"
@@ -73,48 +74,49 @@ RDEPEND="${RDEPEND}
PATCHES=("${FILESDIR}"/${P}-musl.patch)
+# [directory]=license
+declare -A KEEP_BUNDLED=(
+ [Bochs_disasm]=LGPL-2.1+
+ [FreeSurround]=GPL-2+
+
+ # vulkan's API is not backwards-compatible:
+ # new release dropped VK_PRESENT_MODE_RANGE_SIZE_KHR
+ # but dolphin still relies on it, bug #729832
+ [Vulkan]=Apache-2.0
+
+ [cpp-optparse]=MIT
+ # no support for for using system library
+ [glslang]=BSD
+ [imgui]=MIT
+
+ # not packaged, tiny header library
+ [rangeset]=ZLIB
+
+ # FIXME: xxhash can't be found by cmake
+ [xxhash]=BSD-2
+ # no support for for using system library
+ [minizip]=ZLIB
+ # soundtouch uses shorts, not floats
+ [soundtouch]=LGPL-2.1+
+ [cubeb]=ISC
+ [discord-rpc]=MIT
+ # Their build set up solely relies on the build in gtest.
+ [gtest]= # (build-time only)
+ # gentoo's version requires exception support.
+ # dolphin disables exceptions and fails the build.
+ [picojson]=BSD-2
+ # No code to detect shared library.
+ [zstd]=BSD
+)
+LICENSE+=" ${KEEP_BUNDLED[*]}"
+
src_prepare() {
cmake_src_prepare
- # Remove all the bundled libraries that support system-installed
- # preference. See CMakeLists.txt for conditional 'add_subdirectory' calls.
- local keep_sources=(
- Bochs_disasm
- FreeSurround
-
- # vulkan's API is not backwards-compatible:
- # new release dropped VK_PRESENT_MODE_RANGE_SIZE_KHR
- # but dolphin still relies on it, bug #729832
- Vulkan
-
- cpp-optparse
- # no support for for using system library
- glslang
- imgui
-
- # not packaged, tiny header library
- rangeset
-
- # FIXME: xxhash can't be found by cmake
- xxhash
- # no support for for using system library
- minizip
- # soundtouch uses shorts, not floats
- soundtouch
- cubeb
- discord-rpc
- # Their build set up solely relies on the build in gtest.
- gtest
- # gentoo's version requires exception support.
- # dolphin disables exceptions and fails the build.
- picojson
- # No code to detect shared library.
- zstd
- )
local s remove=()
for s in Externals/*; do
[[ -f ${s} ]] && continue
- if ! has "${s#Externals/}" "${keep_sources[@]}"; then
+ if ! has "${s#Externals/}" "${!KEEP_BUNDLED[@]}"; then
remove+=( "${s}" )
fi
done
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index cc0e8a05e213..1a7a4c37e4e5 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -22,7 +22,8 @@ fi
DESCRIPTION="Gamecube and Wii game emulator"
HOMEPAGE="https://dolphin-emu.org/"
-LICENSE="GPL-2"
+# NB: appended below
+LICENSE="GPL-2+"
SLOT="0"
IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg +gui log mgba
profile pulseaudio systemd upnp vulkan"
@@ -72,51 +73,52 @@ BDEPEND="
RDEPEND="${RDEPEND}
vulkan? ( media-libs/vulkan-loader )"
+# [directory]=license
+declare -A KEEP_BUNDLED=(
+ [Bochs_disasm]=LGPL-2.1+
+ [FreeSurround]=GPL-2+
+
+ # vulkan's API is not backwards-compatible:
+ # new release dropped VK_PRESENT_MODE_RANGE_SIZE_KHR
+ # but dolphin still relies on it, bug #729832
+ [Vulkan]=Apache-2.0
+
+ [cpp-optparse]=MIT
+ # no support for for using system library
+ [glslang]=BSD
+ [imgui]=MIT
+
+ # not packaged, tiny header library
+ [rangeset]=ZLIB
+
+ # FIXME: xxhash can't be found by cmake
+ [xxhash]=BSD-2
+ # no support for for using system library
+ [minizip]=ZLIB
+ # soundtouch uses shorts, not floats
+ [soundtouch]=LGPL-2.1+
+ [cubeb]=ISC
+ [discord-rpc]=MIT
+ # Their build set up solely relies on the build in gtest.
+ [gtest]= # (build-time only)
+ # gentoo's version requires exception support.
+ # dolphin disables exceptions and fails the build.
+ [picojson]=BSD-2
+ # No code to detect shared library.
+ [zstd]=BSD
+
+ # This is a stripped-down mGBA for integrated GBA support
+ [mGBA]=MPL-2.0
+)
+LICENSE+=" ${KEEP_BUNDLED[*]}"
+
src_prepare() {
cmake_src_prepare
- # Remove all the bundled libraries that support system-installed
- # preference. See CMakeLists.txt for conditional 'add_subdirectory' calls.
- local KEEP_SOURCES=(
- Bochs_disasm
- FreeSurround
-
- # vulkan's API is not backwards-compatible:
- # new release dropped VK_PRESENT_MODE_RANGE_SIZE_KHR
- # but dolphin still relies on it, bug #729832
- Vulkan
-
- cpp-optparse
- # no support for for using system library
- glslang
- imgui
-
- # not packaged, tiny header library
- rangeset
-
- # FIXME: xxhash can't be found by cmake
- xxhash
- # no support for for using system library
- minizip
- # soundtouch uses shorts, not floats
- soundtouch
- cubeb
- discord-rpc
- # Their build set up solely relies on the build in gtest.
- gtest
- # gentoo's version requires exception support.
- # dolphin disables exceptions and fails the build.
- picojson
- # No code to detect shared library.
- zstd
-
- # This is a stripped-down mGBA for integrated GBA support
- mGBA
- )
local s remove=()
for s in Externals/*; do
[[ -f ${s} ]] && continue
- if ! has "${s#Externals/}" "${keep_sources[@]}"; then
+ if ! has "${s#Externals/}" "${!KEEP_BUNDLED[@]}"; then
remove+=( "${s}" )
fi
done