summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-21 13:00:50 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-10-23 21:07:37 +0200
commit38868ec37e8136d621be27f3ffdd8f2f0fd94331 (patch)
tree8e13acd5526ba8bbdbf82e03eec810e3b5519857 /gnome-base
parentx11-wm/metacity: add 3.54.0 (diff)
downloadgentoo-38868ec37e8136d621be27f3ffdd8f2f0fd94331.tar.gz
gentoo-38868ec37e8136d621be27f3ffdd8f2f0fd94331.tar.bz2
gentoo-38868ec37e8136d621be27f3ffdd8f2f0fd94331.zip
gnome-base/gnome-flashback: add 3.54.0
Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39068 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-flashback/Manifest1
-rw-r--r--gnome-base/gnome-flashback/gnome-flashback-3.54.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/gnome-base/gnome-flashback/Manifest b/gnome-base/gnome-flashback/Manifest
index 86da16ea7bb9..b67c76ca0fe4 100644
--- a/gnome-base/gnome-flashback/Manifest
+++ b/gnome-base/gnome-flashback/Manifest
@@ -1 +1,2 @@
DIST gnome-flashback-3.52.1.tar.xz 917764 BLAKE2B 1191261a2e3627b44a2ca1e52641be860126baa0b7133a9ea51cd35b6a36e6d3390f69e07b6ac1244ac112e7561d73bdb6a404978358b066b01f093d60fa1a09 SHA512 30291be06e18188e20288ee2ac62d9e67a7a079fab1d2169f91d1b7555f663c1381def72220fd13182d7b68af5bd3ebb4c9bd9605f45f92f87783edcb0deba85
+DIST gnome-flashback-3.54.0.tar.xz 919304 BLAKE2B 27277a2af2787c11852120169ccfae2d9e5374bbdd944fe9a3ab98ea4a71a94ee02b8510eeb6a50b4f6cd5d3dd7c194540456c66172191b22311db999a8481d0 SHA512 1d472d5104ff2426fa3cd6341c9684bb9e080e9d5a033212aca00d8eab8c6561142dc47db5489187c87de41c703ab884804f6c43df4ead82a05386918a84ce54
diff --git a/gnome-base/gnome-flashback/gnome-flashback-3.54.0.ebuild b/gnome-base/gnome-flashback/gnome-flashback-3.54.0.ebuild
new file mode 100644
index 000000000000..05edbeed6e2f
--- /dev/null
+++ b/gnome-base/gnome-flashback/gnome-flashback-3.54.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2 toolchain-funcs
+
+DESCRIPTION="GNOME Flashback session"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-flashback/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="elogind systemd"
+REQUIRED_USE="^^ ( elogind systemd )"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2.32.2:2
+ >=x11-libs/gtk+-3.22.0:3[X]
+ >=gnome-base/gnome-desktop-43:3=
+ >=gnome-base/gnome-panel-3.35.2
+ >=media-libs/libcanberra-0.13[gtk3]
+ >=dev-libs/glib-2.67.3:2
+ >=gnome-base/gsettings-desktop-schemas-3.31.0
+ >=sys-auth/polkit-0.97
+ >=app-i18n/ibus-1.5.2
+ >=sys-power/upower-0.99.0:=
+ >=x11-libs/libXrandr-1.5.0
+ >=x11-libs/libXxf86vm-1.1.4
+
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ gnome-base/gdm
+ elogind? ( >=sys-auth/elogind-230 )
+ systemd? ( >=sys-apps/systemd-230:= )
+ net-wireless/gnome-bluetooth:3=
+ x11-libs/libXext
+ >=x11-libs/libXi-1.6.0
+ x11-libs/pango
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ x11-libs/libXfixes
+ media-libs/libpulse[glib]
+ media-libs/alsa-lib
+ sys-libs/pam
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+RDEPEND="${RDEPEND}
+ x11-wm/metacity
+ gnome-base/gnome-panel
+ gnome-base/gnome-settings-daemon
+"
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ --without-compiz-session
+ )
+
+ # Below elogind DESKTOP_* and SCREENSAVER_* pkg-config calls need to match up with
+ # what upstream has each version (libsystemd replaced with libelogind). Explicit
+ # per-version die to force a manual recheck. Only update the explicit version if the
+ # "PKG_CHECK_MODULES([DESKTOP/SCREENSAVER], ...)" blocks did not change; otherwise adjust
+ # elogind conditional block below accordingly first.
+ if ver_test ${PV} -ne 3.54.0; then
+ die "Maintainer has not checked over packages MENU pkg-config deps for elogind support"
+ fi
+
+ if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
+
+ local desktop_modules="glib-2.0 gio-2.0 gio-unix-2.0 gnome-desktop-3.0 gtk+-3.0 libelogind x11"
+ local screensaver_modules="gdm gio-unix-2.0 glib-2.0 gnome-desktop-3.0 gtk+-3.0 libelogind xxf86vm"
+
+ myconf+=(
+ DESKTOP_CFLAGS="$(${pkgconfig} --cflags ${desktop_modules})"
+ DESKTOP_LIBS="$(${pkgconfig} --libs ${desktop_modules})"
+ SCREENSAVER_CFLAGS="$(${pkgconfig} --cflags ${screensaver_modules})"
+ SCREENSAVER_LIBS="$(${pkgconfig} --libs ${screensaver_modules})"
+ )
+ fi
+
+ gnome2_src_configure "${myconf[@]}"
+}