summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/zenity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/Manifest2
-rw-r--r--gnome-extra/zenity/metadata.xml5
-rw-r--r--gnome-extra/zenity/zenity-3.14.0.ebuild49
-rw-r--r--gnome-extra/zenity/zenity-3.16.3.ebuild50
4 files changed, 106 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
new file mode 100644
index 000000000000..0e9d65ca90b4
--- /dev/null
+++ b/gnome-extra/zenity/Manifest
@@ -0,0 +1,2 @@
+DIST zenity-3.14.0.tar.xz 3686756 SHA256 6b57ec6c456af17714dc366e63dabb8bbe0577878b61907805f0186d4d2b892f SHA512 2cb6a0649f5fc6eb6f5ebfbdc4eb6feee4fdc06849783bd8b4879a073a13451ec41a8633c086bde6c8b68afe649f7da0ca65581f263507a2b05708af752d48d8 WHIRLPOOL c14c7d38bb4fc2dbcf0e304170a736f7ff4cefe5ef9f7f8512744cdfe6c1896c4c1e7ff0bae7d529f5050d8081fe86f9ec7e95d54471f32252b36ef6c081984c
+DIST zenity-3.16.3.tar.xz 3878596 SHA256 7fe28016fbc5b1fc6d8f730d8eabd5ae2d8b7d67c8bfa0270811ff0c2bfb1eba SHA512 67da24e56b529fda5c9163cd2d2e68a74cf45434ced929da2ca52909bfcdf264d6e9394947c0a129e0ace08e472765d7bedbbfdfab78b10fe69d78c237d45caa WHIRLPOOL 34ba92009792095c51ab5d81e617e0924bd6e06a49bf1681508512de5ca5649e192f8e4c9d13c132188bfa5414aeefeac0215ddc4a4ec6ccc218b6e0139b22d1
diff --git a/gnome-extra/zenity/metadata.xml b/gnome-extra/zenity/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-extra/zenity/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/gnome-extra/zenity/zenity-3.14.0.ebuild b/gnome-extra/zenity/zenity-3.14.0.ebuild
new file mode 100644
index 000000000000..f62ce0873f61
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.14.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="libnotify test +webkit"
+
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-1.4.0:3 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.14
+ virtual/pkgconfig
+ test? ( app-text/yelp-tools )
+"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2.12
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+
+ gnome2_src_configure \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false) \
+ ITSTOOL=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}
diff --git a/gnome-extra/zenity/zenity-3.16.3.ebuild b/gnome-extra/zenity/zenity-3.16.3.ebuild
new file mode 100644
index 000000000000..5f20fec241da
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.16.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="libnotify test +webkit"
+
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+"
+DEPEND="${RDEPEND}
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ test? ( app-text/yelp-tools )
+"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2.12
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+
+ gnome2_src_configure \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}