summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-10-23 11:49:27 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-26 17:53:32 +0200
commit1fa2ae902d6530954584b085dee7faa1e2532299 (patch)
treecd4fa8c19cd73c2538c7caf832c2205310c4216a /gnome-extra
parentgnome-base/nautilus: Avoid test failure (diff)
downloadgentoo-1fa2ae902d6530954584b085dee7faa1e2532299.tar.gz
gentoo-1fa2ae902d6530954584b085dee7faa1e2532299.tar.bz2
gentoo-1fa2ae902d6530954584b085dee7faa1e2532299.zip
gnome-extra/gnome-calendar: Version bump to 45.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33472 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-calendar/Manifest1
-rw-r--r--gnome-extra/gnome-calendar/gnome-calendar-45.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calendar/Manifest b/gnome-extra/gnome-calendar/Manifest
index fd18f62fc78d..43542ed72fd7 100644
--- a/gnome-extra/gnome-calendar/Manifest
+++ b/gnome-extra/gnome-calendar/Manifest
@@ -1,2 +1,3 @@
DIST gnome-calendar-44.1.tar.xz 430464 BLAKE2B ab58a04a44504a82d48cbc8e45de4066072d66f5702a7acf56b64ad8b46dba4cf38bc156e51da6eb659eaf672f09064b6077fdfe47b2c678b3cb1c34fc4df87f SHA512 318ac8d78b41e352816dc4c5f8510d2e8f5b989cea25cb37af6a1d2af3a54307d8f8cc55649b03b381a53b18dbe826d1c84833841334a2878baedaee45d36f8c
DIST gnome-calendar-45.0.tar.xz 456412 BLAKE2B 714578426aede81f1e48d5f306f55b297aa4dfe27af95e8496bbc4a45047a7804453bcd09292069284984cbf866da9e91a1744572b5fb9e250375809187ac60e SHA512 9e963849e19b5e7f69d9bac639393453d12c9a7a8fb38be12505fc78ffb18f3600f0e459b6633fb156e5cb7e0a2316be08c9341196cefe083489d0ffdf7b8eff
+DIST gnome-calendar-45.1.tar.xz 456436 BLAKE2B 7d095314887c055834c6cbba13a6070eedf521b737976b46c184f09d1fd40ac1f07a436fd8d72174d0ea4cf070bc6acd6e0d81e2630839bd3774cdf751cdf1a4 SHA512 372abcf94c7b49980c9d1a5f7ee6cea1e34760337f2ab8886fdb3207fd3d87f4c45feecfa9156f6f8596f395af8d02469c2db53acf6b718735db94221af8c623
diff --git a/gnome-extra/gnome-calendar/gnome-calendar-45.1.ebuild b/gnome-extra/gnome-calendar/gnome-calendar-45.1.ebuild
new file mode 100644
index 000000000000..df70e09537fb
--- /dev/null
+++ b/gnome-extra/gnome-calendar/gnome-calendar-45.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Manage your online calendars with simple and modern interface"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calendar"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/libical-1.0.1:0=
+ >=gnome-base/gsettings-desktop-schemas-3.21.2
+ >=gnome-extra/evolution-data-server-3.45.1:=[gtk]
+ net-libs/libsoup:3.0
+ >=gui-libs/libadwaita-1.4_alpha:1
+ >=dev-libs/glib-2.67.5:2
+ >=gui-libs/gtk-4.11.2:4
+ >=dev-libs/libgweather-4.2.0:4=
+ >=app-misc/geoclue-2.4:2.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}