summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-11-27 11:34:42 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-11-27 11:45:59 -0600
commit1f3ad75357ccde02e12cdec262dd768fe85396f6 (patch)
tree6288d175b4f2b4b0adfd923c84fd0757614525a9 /gui-libs
parentgui-libs/wlroots: update deps for 0.16.0 (diff)
downloadgentoo-1f3ad75357ccde02e12cdec262dd768fe85396f6.tar.gz
gentoo-1f3ad75357ccde02e12cdec262dd768fe85396f6.tar.bz2
gentoo-1f3ad75357ccde02e12cdec262dd768fe85396f6.zip
gui-libs/wlroots: make seatd and udev optional
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/metadata.xml1
-rw-r--r--gui-libs/wlroots/wlroots-0.16.0.ebuild81
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild6
4 files changed, 86 insertions, 3 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index e307e5dade54..6fcd26feb3b5 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,3 +1,4 @@
DIST wlroots-0.14.0.tar.gz 505461 BLAKE2B d2fa28f64014ef9d840838cb5938af23f6f6b211b62dc352d0d5bb824ccaa7d7a85531e1eca14feeb06d31d59955ff9a913e40a73cad21ed1ebfe76ada39d558 SHA512 83f001133cb4b11a72bb9532b7321655428826662848f67de8e3220a33d9dff4d37c859602bdc319929949d387d014a257b0347039a6649944d7b084c76bb611
DIST wlroots-0.14.1.tar.gz 505840 BLAKE2B fca4d259cdde62da0c196344ce1d0f5dd679d012ff33e3ceb5385b9374667e16d91059a2ba6a318153e79ac2f0a6464e3066e614a13398f8c433f442560d84d2 SHA512 4f557c827f9673eccf208a3644954de80e7355b95cc374cc5e851a47087b227f196e0936c0913d21a6c776c29b74de2d028a100931264e41934c747568d8ebe0
DIST wlroots-0.15.1.tar.gz 565816 BLAKE2B 09b704a55d8b4a5ab19bb0fcdd041635fbbbb8eed94ff6d189ef47f9f86e90178efa8441c7db78839b1145ed79ed016d520d6599e256cdcf49130cda38bc307d SHA512 6228160f2f350a406c612f1048d7075cf2f78206cc84bc16f889d5d0acd614f9e98845fffed03d7067cfdbd7558b77fcc5d8cedc3868d866e476523126a63677
+DIST wlroots-0.16.0.tar.gz 588565 BLAKE2B d1233f85bc4d80bfc65efb04367e136a351efc5e47168e30f061a8b4eecdd4bdbde6355e35211c610285b4d031c754f90c94b49e63c5b2f665890765b139bf76 SHA512 0b56f31284cc250019cda1e80d1660031d397e880a8c1aac2e60d7758bcac26e50144a499c13c61e24fe2664ba1e6cbb8262bfe28c817f4664162b1de592f1b6
diff --git a/gui-libs/wlroots/metadata.xml b/gui-libs/wlroots/metadata.xml
index 7e969054cfe1..d3b3b880db37 100644
--- a/gui-libs/wlroots/metadata.xml
+++ b/gui-libs/wlroots/metadata.xml
@@ -21,6 +21,7 @@
wlroots is developed under the direction of the <pkg>gui-wm/sway</pkg> project.
</longdescription>
<use>
+ <flag name="seatd">Enable libseatd session support</flag>
<flag name="tinywl">Install the minimal wayland client, tinywl</flag>
<flag name="vulkan">Enable support for the vulkan backend renderer</flag>
<flag name="x11-backend">Enable support for handling input/output devices through <pkg>x11-libs/libxcb</pkg></flag>
diff --git a/gui-libs/wlroots/wlroots-0.16.0.ebuild b/gui-libs/wlroots/wlroots-0.16.0.ebuild
new file mode 100644
index 000000000000..d9c6b4603306
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.16.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+ SLOT="0/9999"
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 2)"
+fi
+
+LICENSE="MIT"
+IUSE="tinywl vulkan x11-backend X"
+
+DEPEND="
+ >=dev-libs/libinput-1.14.0:0=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.28
+ media-libs/mesa[egl(+),gles2,gbm(+)]
+ sys-auth/seatd:=
+ virtual/libudev
+ vulkan? (
+ dev-util/glslang:0=
+ dev-util/vulkan-headers:0=
+ media-libs/vulkan-loader:0=
+ )
+ >=x11-libs/libdrm-2.4.114:0=
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0:0=
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xwayland
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ $(meson_use tinywl examples)
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dbackends=drm,libinput$(usex x11-backend ',x11' '')
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use tinywl; then
+ dobin "${BUILD_DIR}"/tinywl/tinywl
+ fi
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index d9c6b4603306..b396b8bae492 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -19,15 +19,15 @@ else
fi
LICENSE="MIT"
-IUSE="tinywl vulkan x11-backend X"
+IUSE="+seatd tinywl +udev vulkan x11-backend X"
DEPEND="
>=dev-libs/libinput-1.14.0:0=
>=dev-libs/wayland-1.21.0
>=dev-libs/wayland-protocols-1.28
media-libs/mesa[egl(+),gles2,gbm(+)]
- sys-auth/seatd:=
- virtual/libudev
+ seatd? ( sys-auth/seatd:= )
+ udev? ( virtual/libudev )
vulkan? (
dev-util/glslang:0=
dev-util/vulkan-headers:0=