summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-26 14:40:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-26 15:50:29 +0200
commitb7b2dfe235617fce32f213156b15336422fac3fe (patch)
tree31855b837ebe90679e69ca29f53a5c7a66ebcda1 /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.26.2 version bump (diff)
downloadgentoo-b7b2dfe235617fce32f213156b15336422fac3fe.tar.gz
gentoo-b7b2dfe235617fce32f213156b15336422fac3fe.tar.bz2
gentoo-b7b2dfe235617fce32f213156b15336422fac3fe.zip
kde-plasma/kwayland-integration: 5.26.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.26.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index bbefe49b188c..924d2576df38 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.25.5.tar.xz 24296 BLAKE2B 30fd0d0c2cb8ce34da692a40d558e7616796475f74ff7fc4212fdded88e7c55271836f160b48907fd3e195f41738c294e40c122bf51ec967861e17bc3d7de3bd SHA512 eabb2040275fd32b4ca1e8a5717a05589a331aac97e21861f36e8ac2b3c683b369d5f40507b0dbebd714dc766d311bd1233043327253e3c5d68de2464e12a342
DIST kwayland-integration-5.26.1.tar.xz 26992 BLAKE2B 574e7884a77e2489b9af64ddc9fb555af6ef0c422abdce54df219438c8af89f460eebc940c84ec08f6e5aeb0b621db048d929ca7ca814fa711909712099b8b5f SHA512 e7e8c1d635ed37d8ae12bc562ce56a7a9bb6a0920219b335e1d9c535e8b5ee7975059cf0891272dfd53e0cabef017312bcb9d56fbca38dd673b21c8465d89801
+DIST kwayland-integration-5.26.2.tar.xz 26964 BLAKE2B fe24d9e6abaeea676e321be74e7ecb68dbf5caf9e27fa6440bd78ed4e0b9e617af17f34ca2d6c0e359ef65ac715fade380efe5b0bfdeab64b179bb595d1f72e8 SHA512 ddf59c8bcda77ca54c7e38b1f1799e243d0b39ceebd33b2021219130b4a3850bddbb63324078f9f4d91bf7c1de7a031fdcd1155b0155809666588d5dafa0f1cd
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.26.2.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.26.2.ebuild
new file mode 100644
index 000000000000..3ecd7fe0998f
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.26.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides integration plugins for various KDE frameworks for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}