summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-01 01:27:28 -0400
committerSam James <sam@gentoo.org>2024-04-01 06:29:28 +0100
commitfc63cf705180dd9f91efa1f0e9bed713d865423b (patch)
tree1a3fcf0812061ec93a688412e7ae7dd174c1b308 /mate-base
parentmedia-libs/ctl: add 1.5.3 (diff)
downloadgentoo-fc63cf705180dd9f91efa1f0e9bed713d865423b.tar.gz
gentoo-fc63cf705180dd9f91efa1f0e9bed713d865423b.tar.bz2
gentoo-fc63cf705180dd9f91efa1f0e9bed713d865423b.zip
mate-base/caja: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/926751 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/caja/caja-1.26.3.ebuild7
-rw-r--r--mate-base/caja/caja-1.27.2.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/mate-base/caja/caja-1.26.3.ebuild b/mate-base/caja/caja-1.26.3.ebuild
index d5d38fb07637..ac48b892bf78 100644
--- a/mate-base/caja/caja-1.26.3.ebuild
+++ b/mate-base/caja/caja-1.26.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MATE_LA_PUNT="yes"
-inherit mate
+inherit flag-o-matic mate
MINOR=$(($(ver_cut 2) % 2))
if [[ ${MINOR} -eq 0 ]]; then
@@ -67,6 +67,11 @@ src_prepare() {
}
src_configure() {
+ # https://bugs.gentoo.org/926751
+ # https://github.com/mate-desktop/caja/issues/1774
+ append-flags -fno-strict-aliasing
+ filter-lto
+
mate_src_configure \
--disable-update-mimedb \
$(use_enable introspection) \
diff --git a/mate-base/caja/caja-1.27.2.ebuild b/mate-base/caja/caja-1.27.2.ebuild
index d610e6043e96..139ea62e6bbd 100644
--- a/mate-base/caja/caja-1.27.2.ebuild
+++ b/mate-base/caja/caja-1.27.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MATE_LA_PUNT="yes"
-inherit mate
+inherit flag-o-matic mate
MINOR=$(($(ver_cut 2) % 2))
if [[ ${MINOR} -eq 0 ]]; then
@@ -69,6 +69,11 @@ src_prepare() {
}
src_configure() {
+ # https://bugs.gentoo.org/926751
+ # https://github.com/mate-desktop/caja/issues/1774
+ append-flags -fno-strict-aliasing
+ filter-lto
+
mate_src_configure \
--disable-update-mimedb \
$(use_enable introspection) \