summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-20 21:49:50 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-20 21:49:50 +0100
commit809585418cd87f9fa202c5e5de0b26d9c2e08dd9 (patch)
treed583a6b7194ee8d0444440ef195d56b5a2317e43 /media-gfx/pngnq
parentnet-im/telegram-desktop: Stabilize 3.5.2-r1 amd64, #835686 (diff)
downloadgentoo-809585418cd87f9fa202c5e5de0b26d9c2e08dd9.tar.gz
gentoo-809585418cd87f9fa202c5e5de0b26d9c2e08dd9.tar.bz2
gentoo-809585418cd87f9fa202c5e5de0b26d9c2e08dd9.zip
media-gfx/pngnq: update EAPI 7 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/pngnq')
-rw-r--r--media-gfx/pngnq/files/pngnq-1.0-Wimplicit-function-declaration.patch10
-rw-r--r--media-gfx/pngnq/pngnq-1.1-r1.ebuild29
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/pngnq/files/pngnq-1.0-Wimplicit-function-declaration.patch b/media-gfx/pngnq/files/pngnq-1.0-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..4b3ffbf0aaad
--- /dev/null
+++ b/media-gfx/pngnq/files/pngnq-1.0-Wimplicit-function-declaration.patch
@@ -0,0 +1,10 @@
+--- a/src/rwpng.c
++++ b/src/rwpng.c
+@@ -31,6 +31,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <zlib.h>
+
+ #include "png.h" /* libpng header */
diff --git a/media-gfx/pngnq/pngnq-1.1-r1.ebuild b/media-gfx/pngnq/pngnq-1.1-r1.ebuild
new file mode 100644
index 000000000000..f8d71e93fc9d
--- /dev/null
+++ b/media-gfx/pngnq/pngnq-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Pngnq is a tool for quantizing PNG images in RGBA format"
+HOMEPAGE="http://pngnq.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD pngnq rwpng"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-libpng14.patch
+ "${FILESDIR}"/${PN}-1.0-libpng15.patch
+ "${FILESDIR}"/${PN}-1.0-Wimplicit-function-declaration.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}