summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Korepanov <kaikaikai@yandex.ru>2021-11-18 13:46:53 +0000
committerFlorian Schmaus <flow@gentoo.org>2021-11-18 15:30:07 +0100
commit938df161efb282c38ac19dabe8bc5c58c4b1d2ff (patch)
treec01a00d0f134c9a3076ed784db75f785f1478503 /net-fs/s3backer/s3backer-1.6.3.ebuild
parentmedia-plugins/x42-plugins: removed obsolete 20210714 (diff)
downloadgentoo-938df161efb282c38ac19dabe8bc5c58c4b1d2ff.tar.gz
gentoo-938df161efb282c38ac19dabe8bc5c58c4b1d2ff.tar.bz2
gentoo-938df161efb282c38ac19dabe8bc5c58c4b1d2ff.zip
net-fs/s3backer: version bump 1.6.3
Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-fs/s3backer/s3backer-1.6.3.ebuild')
-rw-r--r--net-fs/s3backer/s3backer-1.6.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-fs/s3backer/s3backer-1.6.3.ebuild b/net-fs/s3backer/s3backer-1.6.3.ebuild
new file mode 100644
index 000000000000..8ed0433a2964
--- /dev/null
+++ b/net-fs/s3backer/s3backer-1.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="FUSE-based single file backing store via Amazon S3"
+HOMEPAGE="https://github.com/archiecobbs/s3backer"
+SRC_URI="https://github.com/archiecobbs/s3backer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/expat
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-fs/fuse:0
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -e "/docdir=/s:packages/\$(PACKAGE):${PF}:" \
+ -e "/doc_DATA=/d" \
+ -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}