summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/rinetd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/rinetd')
-rw-r--r--net-misc/rinetd/Manifest1
-rw-r--r--net-misc/rinetd/files/rinetd.rc23
-rw-r--r--net-misc/rinetd/metadata.xml7
-rw-r--r--net-misc/rinetd/rinetd-0.62-r1.ebuild34
4 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/rinetd/Manifest b/net-misc/rinetd/Manifest
new file mode 100644
index 000000000000..e260e9f021d7
--- /dev/null
+++ b/net-misc/rinetd/Manifest
@@ -0,0 +1 @@
+DIST rinetd.tar.gz 115541 SHA256 0c68d27c5bd4b16ce4f58a6db514dd6ff37b2604a88b02c1dfcdc00fc1059898
diff --git a/net-misc/rinetd/files/rinetd.rc b/net-misc/rinetd/files/rinetd.rc
new file mode 100644
index 000000000000..9fe4d41e92cf
--- /dev/null
+++ b/net-misc/rinetd/files/rinetd.rc
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting rinetd"
+ /usr/sbin/rinetd
+ eend $?
+}
+
+stop() {
+ local ret
+ ebegin "Stopping rinetd"
+ start-stop-daemon --stop --pidfile /var/run/rinetd.pid
+ ret=$?
+ rm -f /var/run/rinetd.pid
+ eend ${ret}
+}
diff --git a/net-misc/rinetd/metadata.xml b/net-misc/rinetd/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/net-misc/rinetd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/rinetd/rinetd-0.62-r1.ebuild b/net-misc/rinetd/rinetd-0.62-r1.ebuild
new file mode 100644
index 000000000000..911007719253
--- /dev/null
+++ b/net-misc/rinetd/rinetd-0.62-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="redirects TCP connections from one IP address and port to another"
+HOMEPAGE="http://www.boutell.com/rinetd/"
+SRC_URI="http://www.boutell.com/rinetd/http/rinetd.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "s:gcc:$(tc-getCC) \$(CFLAGS) \$(LDFLAGS):" Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dosbin rinetd || die
+ newinitd "${FILESDIR}"/rinetd.rc rinetd
+ doman rinetd.8
+ dodoc CHANGES README
+ dohtml index.html
+}