summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/classified-ads/classified-ads-0.07.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/classified-ads/classified-ads-0.07.ebuild')
-rw-r--r--net-p2p/classified-ads/classified-ads-0.07.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/net-p2p/classified-ads/classified-ads-0.07.ebuild b/net-p2p/classified-ads/classified-ads-0.07.ebuild
new file mode 100644
index 000000000000..31a937f74a6b
--- /dev/null
+++ b/net-p2p/classified-ads/classified-ads-0.07.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="en fi sv"
+PLOCALE_BACKUP="en"
+inherit qt4-r2
+
+DESCRIPTION="Program for displaying classified advertisement items"
+HOMEPAGE="http://katiska.org/classified-ads/"
+SRC_URI="https://github.com/operatornormal/classified-ads/archive/${PV}.tar.gz \
+ -> classified-ads-${PV}.tar.gz \
+ https://github.com/operatornormal/classified-ads/blob/graphics/preprocessed.tar.gz?raw=true \
+ -> classified-ads-graphics-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc test"
+
+DEPEND="dev-libs/openssl:0
+ dev-libs/qjson
+ >=net-libs/libnatpmp-20130911
+ <=net-libs/libnatpmp-20140401-r1
+ >=net-libs/miniupnpc-1.8
+ sys-apps/file
+ dev-qt/qtgui:4[debug?]
+ test? ( dev-libs/libgcrypt:0
+ dev-qt/qttest:4
+ sys-devel/gdb:0 )
+ doc? ( app-doc/doxygen[dot] )"
+RDEPEND="dev-libs/openssl:0
+ dev-libs/qjson
+ >=net-libs/libnatpmp-20130911
+ <=net-libs/libnatpmp-20140401-r1
+ >=net-libs/miniupnpc-1.8
+ sys-apps/file
+ dev-qt/qtgui:4[debug?]"
+
+src_prepare() {
+ # preprocessed graphics are unpacked into wrong directory
+ # so lets move them into correct location:
+ mv ../ui/* ui/ || die
+ # then just run qmake
+ qt4-r2_src_prepare
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use doc; then
+ cd doc || die
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd test || die "test suite missing"
+ qmake || die "test suite configure failed"
+ make
+
+ if [ -e $HOME/.classified_ads/sqlite_db ]; then
+ mv $HOME/.classified_ads/sqlite_db $HOME/.classified_ads/sqlite_db.backup \
+ || die "datafile backup failed"
+ fi
+ ./testca
+ result=$?
+ rm $HOME/.classified_ads/sqlite_db || true
+
+ if [ -e $HOME/.classified_ads/sqlite_db.backup ]; then
+ mv $HOME/.classified_ads/sqlite_db.backup $HOME/.classified_ads/sqlite_db \
+ || die "datafile restore failed"
+ fi
+
+ if [ $result != "0" ]; then
+ die "test failed with code $result"
+ fi
+
+ return $result
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+ use doc && dodoc -r doc/doxygen.generated/html/
+}