summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-02 00:40:02 +0100
committerSam James <sam@gentoo.org>2024-06-02 00:40:02 +0100
commitebc47896111adf52d9d2447a70c9648cf44855a6 (patch)
treef9d0ac2b7f497ea389c7fc66cbda4c43b16c4f98 /sys-apps/findutils
parentsci-biology/ucsc-genome-browser: BDEPEND on cpio (diff)
downloadgentoo-ebc47896111adf52d9d2447a70c9648cf44855a6.tar.gz
gentoo-ebc47896111adf52d9d2447a70c9648cf44855a6.tar.bz2
gentoo-ebc47896111adf52d9d2447a70c9648cf44855a6.zip
sys-apps/findutils: add 4.10.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/Manifest2
-rw-r--r--sys-apps/findutils/findutils-4.10.0.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index 48148583bc1c..7156f51562a6 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1,2 +1,4 @@
+DIST findutils-4.10.0.tar.xz 2240712 BLAKE2B 2eebdcb425c04170d17afb80e7270ba095bd691660d961dcfa731141633d3bb597d0b47d69ed17e891ef884a36d4c232885097e45b41d3d3ac79dbeae6ee2282 SHA512 b8b683d21cd26c6da4f41c56e83cadbda4780f8610a2bbd4b4e34bb1f339c3209721974b03e076d5eef0331fd876d947b398197aad37c29bbcc2e0405c641b34
+DIST findutils-4.10.0.tar.xz.sig 488 BLAKE2B fadd7dbf80a52965d6da641bda21ce00790623cf2c959ed03c1193a22c19f30417733511a739edcb1a0a97892a1257e0e88e32d872f94e71e3ade04776337d3c SHA512 a835153a0671309021be187bf78afee58d9682acb40545aaa9dd187f0ebdea0cfa5583bd03f363243633ea056ddb0a7a6603987ab5e34a608426cb4265ac6d8f
DIST findutils-4.9.0.tar.xz 2046252 BLAKE2B 3ada8903fc552ad2e580a7b631a4b9d941935b3f4231029564c6f2b7b10ba6f2244e2de57f6d79268c5e0481a193f64edbbae637e7a51ae6f495e3eefabf52c9 SHA512 ba4844f4403de0148ad14b46a3dbefd5a721f6257c864bf41a6789b11705408524751c627420b15a52af95564d8e5b52f0978474f640a62ab86a41d20cf14be9
DIST findutils-4.9.0.tar.xz.sig 488 BLAKE2B 7aab47ccb1351f08be03e781332b79d6778ff0d5d7959adf75fa8eab11325ee9971c89972338edfb58daac7f702891a1a5dd8379a703ccfa601e6b99db588197 SHA512 b8e0b5471242912a20b9e468fa27b7f27339af5f7be8918173105262dee0152183bf4cf516844d348b206a694e028490d5d3b190f3aed8c698ba5444941f8dfc
diff --git a/sys-apps/findutils/findutils-4.10.0.ebuild b/sys-apps/findutils/findutils-4.10.0.ebuild
new file mode 100644
index 000000000000..fd4180661649
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.10.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/findutils.asc
+inherit flag-o-matic python-any-r1 verify-sig
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="
+ mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ dev-util/dejagnu
+ )
+ verify-sig? ( sec-keys/openpgp-keys-findutils )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with mlocate,
+ # which is a secure version of locate. See bug #18729.
+ sed \
+ -e '/^SUBDIRS/s@locate@@' \
+ -e '/^built_programs/s@ frcode locate updatedb@@' \
+ -i Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ if use static; then
+ append-flags -pthread
+ append-ldflags -static
+ fi
+
+ append-lfs-flags
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
+ append-cppflags '-D__nonnull\(X\)='
+ fi
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ $(use_with selinux)
+ --libexecdir='$(libdir)'/find
+ # rename to gfind, gxargs for better BSD compatibility
+ --program-prefix=g
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}
+
+src_test() {
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
+src_install() {
+ default
+
+ # symlink to the standard names
+ dosym gfind /usr/bin/find
+ dosym gxargs /usr/bin/xargs
+ dosym gfind.1 /usr/share/man/man1/find.1
+ dosym gxargs.1 /usr/share/man/man1/xargs.1
+}