summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-11-19 10:27:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-11-19 10:29:12 +0000
commita7221a9b751209af88a6bd65f39e0deca1c75bad (patch)
treed61864b21654de630ab759c34a4666c37da3a90a /sys-apps
parenttoolchain.eclass: wire up libdiagonstics (diff)
downloadgentoo-a7221a9b751209af88a6bd65f39e0deca1c75bad.tar.gz
gentoo-a7221a9b751209af88a6bd65f39e0deca1c75bad.tar.bz2
gentoo-a7221a9b751209af88a6bd65f39e0deca1c75bad.zip
sys-apps/syd: Fix static build
Enables static-pie, which is all in all good for us Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/syd/syd-3.28.3-r1.ebuild (renamed from sys-apps/syd/syd-3.28.3.ebuild)2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-apps/syd/syd-3.28.3.ebuild b/sys-apps/syd/syd-3.28.3-r1.ebuild
index 985a8cdd7501..bf2327917016 100644
--- a/sys-apps/syd/syd-3.28.3.ebuild
+++ b/sys-apps/syd/syd-3.28.3-r1.ebuild
@@ -298,7 +298,7 @@ src_configure() {
if use static; then
export LIBSECCOMP_LINK_TYPE="static"
export LIBSECCOMP_LIB_PATH=$(pkgconf --variable=libdir libseccomp)
- export RUSTFLAGS+="-Clink-args=-static -Clink-args=-no-pie -Clink-args=-Wl,-Bstatic -Ctarget-feature=+crt-static"
+ export RUSTFLAGS+="-Ctarget-feature=+crt-static"
cargo_src_configure
else
local myfeatures=( "oci" )