summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-11 07:04:59 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-11 07:06:36 +0200
commit3b9ef37e4708ad6b733860dd49402c3762c629ee (patch)
tree2f5006c762998a4febffb1daae6e73b71f1c5017 /sys-block
parentsys-block/parted: Do not inherit flag-o-matic.eclass (diff)
downloadgentoo-3b9ef37e4708ad6b733860dd49402c3762c629ee.tar.gz
gentoo-3b9ef37e4708ad6b733860dd49402c3762c629ee.tar.bz2
gentoo-3b9ef37e4708ad6b733860dd49402c3762c629ee.zip
sys-block/parted: Version 3.3
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/Manifest1
-rw-r--r--sys-block/parted/parted-3.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-block/parted/Manifest b/sys-block/parted/Manifest
index 79ed244b1a8d..642b27d62b62 100644
--- a/sys-block/parted/Manifest
+++ b/sys-block/parted/Manifest
@@ -1,4 +1,5 @@
DIST parted-3.2.tar.xz 1655244 BLAKE2B 56608590b26a9b5266dacf3698d990b730bdb35d9374d1da57103fbef3ef5037e40dd2fe0f523ca8e0e75401a3b25cf543e5ca5c94cf410bbaa62ea15d6f0ba3 SHA512 4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a705196713864451fa9e11d32777e16c68982877945c5efd9ea5f8252cb20e1c4
+DIST parted-3.3.tar.xz 1757432 BLAKE2B d1e248cd8fdce22d4957055d65f9f93333505229f92174f343897422a31a43f3d35ea06f8f1bdafd254e4629c5890ec38d6b75d3b499c39a9ada4a8d5f9d9d8f SHA512 d1384694a491aa53bab6206fdeccd1d192de2ed379fe25aa865dd6aa06ed945a728e85b2ccc2fb23f5aa9dfee4a8bd8f0f2be1dd386cb8e8861b73382c6a07e4
DIST parted_3.2-20.debian.tar.xz 87496 BLAKE2B 4409826b35b42093f16f80b1ab2f41b4caf2264c9dcfe9572fa1ddf5f51eeffa2208fc187bd7a98290ee2df92604928eae84fd2fdee78d688ec19e81f8b9efac SHA512 83f14befdd7d048976572b3e2eebfaa42649458cbcfd659db704737dce991980ddb2bc65013c5b31b04a17fc17fb756da0dda76edbcba93708afca34c56e0d22
DIST parted_3.2-23.debian.tar.xz 88152 BLAKE2B 5e69a5799cc909bf54d1dcd1c7a8f7fe5dd7ce46b03957406f4a6118480d5acca3a165cc16b720fd03a89339fcfb46844d470079c4e10a4683e270c9e804c245 SHA512 7f449a24d1ea75a185b5fd589fea73a2f0944f1276288ece2790c5889de6adf8354f94388046a25b2dbf5735759f6010397f140607320a4de348cf77f8c75b09
DIST parted_3.2-25.debian.tar.xz 88524 BLAKE2B e994ca8a68f700773e0a67657d59793ea130a5c7e9eca31688fa48e7133a0c350446b8c0a175ac2f59aca8c2fe1ef419a94f3f6f0547b0b25cca329c6f569571 SHA512 2d4e52513b016ef67b203db577641cd56b4d2d013e1bc186b665ab47d0f6c673321b108f81d36caaa0fd14c555d8336a2556a60cccbeccb9d2cf98a85872d949
diff --git a/sys-block/parted/parted-3.3.ebuild b/sys-block/parted/parted-3.3.ebuild
new file mode 100644
index 000000000000..aa855d377c10
--- /dev/null
+++ b/sys-block/parted/parted-3.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted"
+SRC_URI="
+ mirror://gnu/${PN}/${P}.tar.xz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+debug device-mapper nls readline selinux static-libs"
+RESTRICT="test"
+
+# specific version for gettext needed
+# to fix bug 85999
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? ( >=sys-libs/readline-5.2:0= >=sys-libs/ncurses-5.7-r7:0= )
+ selinux? ( sys-libs/libselinux )
+ elibc_uclibc? ( dev-libs/libiconv )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+)
+
+src_configure() {
+ use elibc_uclibc && append-libs -liconv
+ econf \
+ $(use_enable debug) \
+ $(use_enable device-mapper) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ $(use_with readline) \
+ --disable-rpath \
+ --disable-silent-rules
+}
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}