summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-21 15:12:55 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-21 16:39:09 +0100
commit33967a13b18c9e062b06767247ce3fcc3033936f (patch)
treef1f39eb40e0b644b27f165c9bdeab419fcfbbc19 /sys-cluster/libquo
parentsys-cluster/libquo: update EAPI 6 -> 8 (diff)
downloadgentoo-33967a13b18c9e062b06767247ce3fcc3033936f.tar.gz
gentoo-33967a13b18c9e062b06767247ce3fcc3033936f.tar.bz2
gentoo-33967a13b18c9e062b06767247ce3fcc3033936f.zip
sys-cluster/libquo: add 1.3.1, drop 1.2.9
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/libquo')
-rw-r--r--sys-cluster/libquo/Manifest2
-rw-r--r--sys-cluster/libquo/libquo-1.3.1.ebuild (renamed from sys-cluster/libquo/libquo-1.2.9.ebuild)12
2 files changed, 9 insertions, 5 deletions
diff --git a/sys-cluster/libquo/Manifest b/sys-cluster/libquo/Manifest
index 6b7246cbd88f..fdd02f778e8b 100644
--- a/sys-cluster/libquo/Manifest
+++ b/sys-cluster/libquo/Manifest
@@ -1 +1 @@
-DIST libquo-1.2.9.tar.gz 788507 BLAKE2B c6240ea265dfc34fd02b04f5ff9dcfa194c82789d3caa9553eb65ad25e9e883dfd320d4b095693b88778e74cbd11c207bcc9c5c133f03ec5a25e7c633853cd0d SHA512 732a737b9d53ca7b530ae5ecfd79cc9200f86e6a39f4c529975b204631165a178f6bb87228985222bf623f2581ecc29c774e8480ce9ebfcace12e14c49f98e62
+DIST libquo-1.3.1.tar.gz 1020369 BLAKE2B d7c3906e1211239a1329fd17799b45441bdf45e252ba57d13e4faece8d89b5964c558ab5b71295541d76568fea7530f868f82979998402533506c8eaf6485229 SHA512 02ab71f0c35a143b4be1960cebef23fcfd2ad7cc81edfd917d09482662ba3993045434c623caf19cf2983b3790ebc0e53bba7d9895b089eadaf39589ddff1579
diff --git a/sys-cluster/libquo/libquo-1.2.9.ebuild b/sys-cluster/libquo/libquo-1.3.1.ebuild
index 9fec47663d07..04abe2b0571d 100644
--- a/sys-cluster/libquo/libquo-1.2.9.ebuild
+++ b/sys-cluster/libquo/libquo-1.3.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD=90
@@ -10,14 +10,13 @@ inherit fortran-2
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/lanl/${PN}.git"
- inherit git-r3
- AUTOTOOLS_AUTORECONF=1
+ inherit autotools git-r3
else
SRC_URI="https://lanl.github.io/${PN}/dists/${P}.tar.gz"
KEYWORDS="~amd64"
fi
-DESCRIPTION="run-time tuning of process binding policies made easy"
+DESCRIPTION="Run-time tuning of process binding policies made easy"
HOMEPAGE="https://lanl.github.io/libquo/"
LICENSE="BSD"
@@ -32,6 +31,11 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
src_configure() {
econf CC=mpicc FC=$(usex fortran mpif90 false)
}