summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-24 14:36:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-24 14:36:41 +0200
commit546650c382145559cb3e3d145010a7e856a5e5f1 (patch)
tree3435c5586f0506a0181775eee5f7e73733ccbfb0 /sys-fs/lvm2
parentsys-fs/lvm2: try to detect and warn for problematic /run permissions (diff)
downloadgentoo-546650c382145559cb3e3d145010a7e856a5e5f1.tar.gz
gentoo-546650c382145559cb3e3d145010a7e856a5e5f1.tar.bz2
gentoo-546650c382145559cb3e3d145010a7e856a5e5f1.zip
sys-fs/lvm2: show some ewarns in pkg_postinst only once
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.187-r2.ebuild13
-rw-r--r--sys-fs/lvm2/lvm2-2.03.10.ebuild10
2 files changed, 16 insertions, 7 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.187-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.187-r2.ebuild
index 3111a305fc4f..2bc6f354e530 100644
--- a/sys-fs/lvm2/lvm2-2.02.187-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.187-r2.ebuild
@@ -266,11 +266,14 @@ src_install() {
}
pkg_postinst() {
- ewarn "Make sure the \"lvm\" init script is in the runlevels:"
- ewarn "# rc-update add lvm boot"
- ewarn
- ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
- ewarn "to enable lvm autoactivation and metadata caching."
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ ewarn "Make sure the \"lvm\" init script is in the runlevels:"
+ ewarn "# rc-update add lvm boot"
+ ewarn
+ ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
+ ewarn "to enable lvm autoactivation and metadata caching."
+ fi
if use udev && [[ -d /run ]] ; then
local permission_run_expected="drwxr-xr-x"
diff --git a/sys-fs/lvm2/lvm2-2.03.10.ebuild b/sys-fs/lvm2/lvm2-2.03.10.ebuild
index 66bf4be80bc6..c1a7dbc3b20a 100644
--- a/sys-fs/lvm2/lvm2-2.03.10.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.10.ebuild
@@ -253,8 +253,14 @@ src_install() {
}
pkg_postinst() {
- ewarn "Make sure the \"lvm\" init script is in the runlevels:"
- ewarn "# rc-update add lvm boot"
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ ewarn "Make sure the \"lvm\" init script is in the runlevels:"
+ ewarn "# rc-update add lvm boot"
+ ewarn
+ ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
+ ewarn "to enable lvm autoactivation and metadata caching."
+ fi
if use udev && [[ -d /run ]] ; then
local permission_run_expected="drwxr-xr-x"