summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-13 02:50:51 +0100
committerSam James <sam@gentoo.org>2022-10-13 02:51:18 +0100
commit60077257913d961895b343c5126ee4bdeb77ca3c (patch)
tree346844d93c290f377b87abc2bff0050a62239b78 /www-client
parentwww-client/elinks: add github upstream metadata (diff)
downloadgentoo-60077257913d961895b343c5126ee4bdeb77ca3c.tar.gz
gentoo-60077257913d961895b343c5126ee4bdeb77ca3c.tar.bz2
gentoo-60077257913d961895b343c5126ee4bdeb77ca3c.zip
www-client/elinks: add 0.15.1
Bug: https://bugs.gentoo.org/635110 Bug: https://bugs.gentoo.org/864127 Closes: https://bugs.gentoo.org/780672 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/elinks/Manifest1
-rw-r--r--www-client/elinks/elinks-0.15.1.ebuild148
-rw-r--r--www-client/elinks/elinks-9999.ebuild162
3 files changed, 228 insertions, 83 deletions
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index 612a84d475f6..ccbe603223be 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1 +1,2 @@
DIST elinks-0.13.5.tar.gz 3600196 BLAKE2B e1e51674b5630d6dab3de3030aee671876750fc97808bf4dca50b505fa2c31af669c4c3773b3830186fb98acda5c692ff1902c6e1240251ea699103a70bb4e43 SHA512 786f6142c03bca4a47a1043ca4f9c36aab431d192eb13bcad14c1da391f5746779a8f65e53eb781dff79f619ceb3ed30ef939eae8d81f64251fad9b803c0ae7b
+DIST elinks-0.15.1.tar.xz 1997208 BLAKE2B dcec7054d417842e709f26bab53ddb1bf43556de4c69d116ad1e049664bc7c5a5513f02cee500d591252b439a66f354079e2e3eff5692202102cb900e06340c2 SHA512 677eeeeab3fc24dcfe4e7248a9c1a8e07083ebd13bd9923d89702a04dbe1c3e4d4038029c095881183d7f11ae2c5317ff7e5458320644fde0c176378b89068d8
diff --git a/www-client/elinks/elinks-0.15.1.ebuild b/www-client/elinks/elinks-0.15.1.ebuild
new file mode 100644
index 000000000000..1ea79ed7f5de
--- /dev/null
+++ b/www-client/elinks/elinks-0.15.1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+LUA_COMPAT=( lua5-{1,2} )
+
+inherit meson lua-single python-any-r1
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rkd77/felinks"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rkd77/elinks/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn
+ lua lzma +mouse nls nntp perl samba ssl tre unicode X xml zlib zstd"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2:=[unicode(+)]
+ brotli? ( app-arch/brotli:= )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gpm? (
+ >=sys-libs/gpm-1.20.0-r5
+ )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
+ idn? ( net-dns/libidn:= )
+ lua? ( ${LUA_DEPS} )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl:= )
+ samba? ( net-fs/samba )
+ ssl? (
+ !gnutls? ( dev-libs/openssl:= )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ tre? ( dev-libs/tre )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -D88-colors=true
+ -D256-colors=true
+ $(meson_use bittorrent)
+ $(meson_use brotli)
+ $(meson_use bzip2 bzlib)
+ $(usex debug '-Ddebug=true' '-Dfastmem=true')
+ $(meson_use finger)
+ $(meson_use ftp)
+ -Dfsp=false
+ -Dgemini=false
+ -Dgettext=true
+ $(meson_use gopher)
+ $(meson_use gpm)
+ $(meson_use guile)
+ -Dgssapi=false
+ -Dhtml-highlight=true
+ $(meson_use idn)
+ -Dipv6=true
+ -Dleds=true
+ -Dlibev=false
+ -Dlibevent=false
+ -Dluapkg=$(usex lua ${ELUA:-0} '')
+ $(meson_use lzma)
+ $(meson_use mouse)
+ #-Dmujs=false
+ $(meson_use nls)
+ $(meson_use nntp)
+ $(meson_use perl)
+ -Dpython=false
+ -Dquickjs=false
+ -Druby=false
+ $(meson_use samba smb)
+ -Dsm-scripting=false
+ -Dspidermonkey=false
+ -Dterminfo=true
+ $(meson_use tre)
+ -Dtrue-color=true
+ $(meson_use xml xbel)
+ $(meson_use X x)
+ $(meson_use zlib)
+ $(meson_use zstd)
+ )
+
+ if use ssl ; then
+ if use gnutls ; then
+ emesonargs+=( -Dgnutls=true )
+ else
+ emesonargs+=( -Dopenssl=true)
+ fi
+ else
+ emesonargs+=( -Dgnutls=false -Dopenssl=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+}
+
+pkg_postinst() {
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using ${EROOT}/usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at ${EROOT}/etc/elinks/keybind-full.sample and"
+ elog "${EROOT}/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index d5b093e3bfd6..1ea79ed7f5de 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,40 +1,46 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
LUA_COMPAT=( lua5-{1,2} )
-inherit autotools git-r3 lua-single python-any-r1
-
-EGIT_REPO_URI="https://github.com/rkd77/felinks"
+inherit meson lua-single python-any-r1
DESCRIPTION="Advanced and well-established text-mode web browser"
HOMEPAGE="http://elinks.or.cz/"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rkd77/felinks"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rkd77/elinks/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn ipv6
- lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib zstd"
-
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn
+ lua lzma +mouse nls nntp perl samba ssl tre unicode X xml zlib zstd"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-BDEPEND="virtual/pkgconfig"
+
RDEPEND="
+ >=sys-libs/ncurses-5.2:=[unicode(+)]
brotli? ( app-arch/brotli:= )
bzip2? ( >=app-arch/bzip2-1.0.2 )
- gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
+ gpm? (
+ >=sys-libs/gpm-1.20.0-r5
+ )
guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
idn? ( net-dns/libidn:= )
lua? ( ${LUA_DEPS} )
+ lzma? ( app-arch/xz-utils )
perl? ( dev-lang/perl:= )
- ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
samba? ( net-fs/samba )
ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
+ !gnutls? ( dev-libs/openssl:= )
gnutls? ( net-libs/gnutls:= )
)
tre? ( dev-libs/tre )
@@ -44,85 +50,75 @@ RDEPEND="
)
xml? ( >=dev-libs/expat-1.95.4 )
zlib? ( >=sys-libs/zlib-1.1.4 )
- zstd? ( app-arch/zstd:= )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-parallel-make.patch
-)
-
-src_unpack() {
- default
- git-r3_src_unpack
-}
-
-src_prepare() {
- default
-
- sed -i -e 's/-Werror//' configure* || die
-
- eautoreconf
-}
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}"/etc/elinks
- --enable-leds
- --enable-88-colors
- --enable-256-colors
- --enable-true-color
- --enable-html-highlight
- --without-spidermonkey
- $(use_with gpm)
- $(use_with brotli)
- $(use_with bzip2 bzlib)
- $(use_with guile)
- $(use_with idn)
- $(use_with lua luapkg lua)
- $(use_with perl)
- $(use_with ruby)
- $(use_with tre)
- $(use_with X x)
- $(use_with zlib)
- $(use_with zstd)
- $(use_enable bittorrent)
- $(use_enable finger)
- $(use_enable ftp)
- $(use_enable gopher)
- $(use_enable ipv6)
- $(use_enable mouse)
- $(use_enable nls)
- $(use_enable nntp)
- $(use_enable samba smb)
- $(use_enable xml xbel)
+ local emesonargs=(
+ -D88-colors=true
+ -D256-colors=true
+ $(meson_use bittorrent)
+ $(meson_use brotli)
+ $(meson_use bzip2 bzlib)
+ $(usex debug '-Ddebug=true' '-Dfastmem=true')
+ $(meson_use finger)
+ $(meson_use ftp)
+ -Dfsp=false
+ -Dgemini=false
+ -Dgettext=true
+ $(meson_use gopher)
+ $(meson_use gpm)
+ $(meson_use guile)
+ -Dgssapi=false
+ -Dhtml-highlight=true
+ $(meson_use idn)
+ -Dipv6=true
+ -Dleds=true
+ -Dlibev=false
+ -Dlibevent=false
+ -Dluapkg=$(usex lua ${ELUA:-0} '')
+ $(meson_use lzma)
+ $(meson_use mouse)
+ #-Dmujs=false
+ $(meson_use nls)
+ $(meson_use nntp)
+ $(meson_use perl)
+ -Dpython=false
+ -Dquickjs=false
+ -Druby=false
+ $(meson_use samba smb)
+ -Dsm-scripting=false
+ -Dspidermonkey=false
+ -Dterminfo=true
+ $(meson_use tre)
+ -Dtrue-color=true
+ $(meson_use xml xbel)
+ $(meson_use X x)
+ $(meson_use zlib)
+ $(meson_use zstd)
)
- if use debug ; then
- myconf+=( --enable-debug )
- else
- myconf+=( --enable-fastmem )
- fi
-
if use ssl ; then
if use gnutls ; then
- myconf+=( --with-gnutls )
+ emesonargs+=( -Dgnutls=true )
else
- myconf+=( --with-openssl="${EPREFIX}"/usr )
+ emesonargs+=( -Dopenssl=true)
fi
else
- myconf+=( --without-openssl --without-gnutls )
+ emesonargs+=( -Dgnutls=false -Dopenssl=false )
fi
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake V=1
+ meson_src_configure
}
src_install() {
- emake V=1 DESTDIR="${D}" install
+ meson_src_install
insinto /etc/elinks
newins contrib/keybind-full.conf keybind-full.sample
@@ -142,10 +138,10 @@ src_install() {
pkg_postinst() {
elog "You may want to convert your html.cfg and links.cfg of"
elog "Links or older ELinks versions to the new ELinks elinks.conf"
- elog "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog "using ${EROOT}/usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
elog
- elog "Please have a look at /etc/elinks/keybind-full.sample and"
- elog "/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog "Please have a look at ${EROOT}/etc/elinks/keybind-full.sample and"
+ elog "${EROOT}/etc/elinks/keybind.conf.sample for some bindings examples."
elog
elog "You will have to set your TERM variable to 'xterm-256color'"
elog "to be able to use 256 colors in elinks."