summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2023-09-12 12:18:09 +0200
committerMatt Turner <mattst88@gentoo.org>2023-12-10 13:42:19 -0500
commit1eb8553602d35c161fa78e972df5be39aa1ec73a (patch)
tree4e832c5c16de7f0c2767fd85d8e227fcf7ebf7f4 /x11-libs/libXfont2
parentx11-libs/libxcb: Enable large file support (diff)
downloadgentoo-1eb8553602d35c161fa78e972df5be39aa1ec73a.tar.gz
gentoo-1eb8553602d35c161fa78e972df5be39aa1ec73a.tar.bz2
gentoo-1eb8553602d35c161fa78e972df5be39aa1ec73a.zip
x11-libs/libXfont2: only depend on libbsd when necessary
With glibc >=2.38 we no longer need to unconditionally depend on libbsd. This brings libXfont2 in line with other X libs. Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/32736 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXfont2')
-rw-r--r--x11-libs/libXfont2/libXfont2-2.0.6-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/libXfont2/libXfont2-2.0.6-r1.ebuild b/x11-libs/libXfont2/libXfont2-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..c20b014b99f8
--- /dev/null
+++ b/x11-libs/libXfont2/libXfont2-2.0.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_PACKAGE_NAME=libxfont
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="bzip2 truetype"
+
+RDEPEND="sys-libs/zlib
+ elibc_glibc? ( || ( >=sys-libs/glibc-2.38 dev-libs/libbsd ) )
+ x11-libs/libfontenc
+ bzip2? ( app-arch/bzip2 )
+ truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_enable doc devel-docs)
+ $(use_with doc xmlto)
+ $(use_with bzip2)
+ $(use_enable truetype freetype)
+ --without-fop
+ )
+ xorg-3_src_configure
+}